Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-science
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-science@g.o
From: Steven Trogdon <strogdon@...>
Subject: Re: sci-mathematics/sage-4.7.1 and numpy version
Date: Wed, 24 Aug 2011 10:47:00 -0500
On Wed, 24 Aug 2011 12:03:19 +0200
rose@... wrote:

> Hi,
> 
> I just installed more or less succesful sage. During the installation  
> numpy was downgraded from numpy-1.6.1 to numpy-1.5.1.
> Now every 'emerge -uvDN world' complaines about;
> 
> WARNING: One or more updates have been skipped due to a dependency conflict:
> 
> dev-python/numpy:0
> 
>    (dev-python/numpy-1.6.1::gentoo, ebuild scheduled for merge) conflicts with
>      ~dev-python/numpy-1.5.1 required by  
> (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed)
> 
> dev-python/pexpect:0
> 
>    (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for  
> merge) conflicts with
>      ~dev-python/pexpect-2.0 required by  
> (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed)
> 
> If I try to install couchdb, numpy-1.6.1 will be installed again:
> 
> root@caiman:/root(4)# emerge -pvuDN couchdb
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [ebuild  N     ] dev-lang/erlang-14.2.3  USE="doc emacs java odbc smp  
> ssl tk wxwidgets -halfword -hipe -kpoll -sctp" 98,075 kB
> [ebuild  N     ] dev-db/couchdb-1.1.0  USE="-test" 1,063 kB
> [ebuild     U  ] dev-python/numpy-1.6.1 [1.5.1] USE="doc lapack -test" 0 kB
> 
> Should I mask numpy-1.6.1 or how are the chances that sage will work  
> with numpy-1.6.1?
> 
At least until this Bug

https://bugs.gentoo.org/show_bug.cgi?id=371099

is resolved (sog) sage requires ~numpy-1.5.1

I'm not sure exactly the impact on your system of masking >=numpy-1.6.0 but you
could try that and see what emerge -puDNv world gives. I don't see which
component, if any, of couchdb is pulling in numpy or where else numpy is
needed on your system. Oh, and you will also have to mask >=pexpect-2.4

Steve
Attachment:
signature.asc (PGP signature)
Replies:
Re: sci-mathematics/sage-4.7.1 and numpy version
-- fbissey
Re: sci-mathematics/sage-4.7.1 and numpy version
-- rose
References:
sci-mathematics/sage-4.7.1 and numpy version
-- rose
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
sci-mathematics/sage-4.7.1 and numpy version
Next by thread:
Re: sci-mathematics/sage-4.7.1 and numpy version
Previous by date:
sci-mathematics/sage-4.7.1 and numpy version
Next by date:
More than 200 hundred errors in testsuite


Updated Jul 05, 2012

Summary: Archive of the gentoo-science mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.