Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-science
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-science@g.o
From: fbissey@...
Subject: clisp and pari-2.5
Date: Tue, 23 Aug 2011 10:00:02 +1200
Hi,

A week or two ago, Andrey shared his concerned about the incompatibilities
between clisp and pari-2.5.0. I have looked a the situation a bit more deeply
and a fix won't be easy. clisp has been a few deprecated object for a while.
Also the glue between libpari and lisp has been done right on the lisp side. I
am not confident about that.

I think it would be prudent to restrict clisp to pari-2.3 for now. Hopefully
clisp upstream will move to pari-2.5. It certainly will be painful.
Apart from slotting we could possibly ship a separate libpari-2.3 sitting on its
own (i.e. without the gp interpreter or the help system, just libpari and its
headers). That would be an extreme measure if we decide to get rid of pari-2.3
and clisp cannot be fixed.

Francois



Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[sage-on-gentoo] 4.7.1 and the testsuite useflag
Next by thread:
sci-mathematics/sage-4.7.1 and numpy version
Previous by date:
[sage-on-gentoo] 4.7.1 and the testsuite useflag
Next by date:
Re: g-cran master and portage master incompatible


Updated Jul 05, 2012

Summary: Archive of the gentoo-science mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.