Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-science
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-science@g.o, Steven Trogdon <strogdon@...>
From: rose@...
Subject: Re: sci-mathematics/sage-4.7.1 and numpy version
Date: Thu, 25 Aug 2011 00:21:33 +0200
Quoting Steven Trogdon <strogdon@...>:

> On Wed, 24 Aug 2011 12:03:19 +0200
> rose@... wrote:
>
>> Hi,
>>
>> I just installed more or less succesful sage. During the installation
>> numpy was downgraded from numpy-1.6.1 to numpy-1.5.1.
>> Now every 'emerge -uvDN world' complaines about;
>>
>> WARNING: One or more updates have been skipped due to a dependency conflict:
>>
>> dev-python/numpy:0
>>
>>    (dev-python/numpy-1.6.1::gentoo, ebuild scheduled for merge)   
>> conflicts with
>>      ~dev-python/numpy-1.5.1 required by
>> (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed)
>>
>> dev-python/pexpect:0
>>
>>    (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for
>> merge) conflicts with
>>      ~dev-python/pexpect-2.0 required by
>> (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed)
>>
>> If I try to install couchdb, numpy-1.6.1 will be installed again:
>>
>> root@caiman:/root(4)# emerge -pvuDN couchdb
>>
>> These are the packages that would be merged, in order:
>>
>> Calculating dependencies... done!
>> [ebuild  N     ] dev-lang/erlang-14.2.3  USE="doc emacs java odbc smp
>> ssl tk wxwidgets -halfword -hipe -kpoll -sctp" 98,075 kB
>> [ebuild  N     ] dev-db/couchdb-1.1.0  USE="-test" 1,063 kB
>> [ebuild     U  ] dev-python/numpy-1.6.1 [1.5.1] USE="doc lapack -test" 0 kB
>>
>> Should I mask numpy-1.6.1 or how are the chances that sage will work
>> with numpy-1.6.1?
>>
> At least until this Bug
>
> https://bugs.gentoo.org/show_bug.cgi?id=371099
>
> is resolved (sog) sage requires ~numpy-1.5.1
>
> I'm not sure exactly the impact on your system of masking   
> >=numpy-1.6.0 but you
> could try that and see what emerge -puDNv world gives. I don't see which
> component, if any, of couchdb is pulling in numpy or where else numpy is
> needed on your system. Oh, and you will also have to mask >=pexpect-2.4
>
> Steve
>

Thanks Steve,

OK, I masked:

> =dev-python/numpy-1.6.0
> =dev-python/pexpect-2.4

The following installation of couchdb was no problem, also 'emerge  
-puvDN world' did not complain about any conflicts. But I made the  
mistake to delete scipy. Now 'emerge scipy' fails with:
...
RefactoringTool:  
/var/tmp/portage/sci-libs/scipy-0.9.0-r1/work/scipy-0.9.0/build/py3k/scipy/sparse/linalg/isolve/setup.py
RefactoringTool:  
/var/tmp/portage/sci-libs/scipy-0.9.0-r1/work/scipy-0.9.0/build/py3k/scipy/integrate/setup.py
/var/tmp/portage/sci-libs/scipy-0.9.0-r1/work/scipy-0.9.0/build/py3k/scipy/io/__init__.py
/var/tmp/portage/sci-libs/scipy-0.9.0-r1/work/scipy-0.9.0/build/py3k/scipy/io/matlab/mio4.py
...
/var/tmp/portage/sci-libs/scipy-0.9.0-r1/work/scipy-0.9.0/build/py3k/scipy/integrate/ode.py
/var/tmp/portage/sci-libs/scipy-0.9.0-r1/work/scipy-0.9.0/build/py3k/scipy/integrate/quadpack.py
blas_opt_info:
blas_mkl_info:
libraries mkl,vml,guide not found in /usr/local/lib64
libraries mkl,vml,guide not found in /usr/local/lib
libraries mkl,vml,guide not found in /usr/lib64
libraries mkl,vml,guide not found in /usr/lib
NOT AVAILABLE

atlas_blas_threads_info:
Setting PTATLAS=ATLAS
Warning: No configuration returned, assuming  
unavailable./usr/lib64/python3.2/site-packages/numpy/distutils/system_info.py:527: UserWarning: Specified path is  
invalid.
warnings.warn('Specified path %s is invalid.' % d)
libraries atlcblas,f77blas,m,atlas not found in /usr/lib64
NOT AVAILABLE
...
blas_src_info:
NOT AVAILABLE

/usr/lib64/python3.2/site-packages/numpy/distutils/system_info.py:1411:  
UserWarning:
Blas (http://www.netlib.org/blas/) sources not found.
Directories to search for the sources can be specified in the
numpy/distutils/site.cfg file (section [blas_src]) or by setting
the BLAS_SRC environment variable.
warnings.warn(BlasSrcNotFoundError.__doc__)
Traceback (most recent call last):
File "setup.py", line 181, in <module>
...
File  
"/usr/lib64/python3.2/site-packages/numpy/distutils/system_info.py",  
line 461, in get_info
raise self.notfounderror(self.notfounderror.__doc__)
numpy.distutils.system_info.BlasNotFoundError:
Blas (http://www.netlib.org/blas/) libraries not found.
Directories to search for the libraries can be specified in the
numpy/distutils/site.cfg file (section [blas]) or by setting
the BLAS environment variable.
* ERROR: sci-libs/scipy-0.9.0-r1 failed (compile phase):
* Building failed with CPython 3.2 in distutils_building() function


USE_PYTHON="2.7" 'emerge -v1 scipy'





Replies:
Re: sci-mathematics/sage-4.7.1 and numpy version
-- Juergen Rose
Re: sci-mathematics/sage-4.7.1 and numpy version
-- fbissey
References:
sci-mathematics/sage-4.7.1 and numpy version
-- rose
Re: sci-mathematics/sage-4.7.1 and numpy version
-- Steven Trogdon
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: sci-mathematics/sage-4.7.1 and numpy version
Next by thread:
Re: sci-mathematics/sage-4.7.1 and numpy version
Previous by date:
Re: More than 200 hundred errors in testsuite
Next by date:
Re: sci-mathematics/sage-4.7.1 and numpy version


Updated Jun 15, 2012

Summary: Archive of the gentoo-science mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.