Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-science
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-science@g.o
From: rose@...
Subject: Re: sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
Date: Mon, 10 Oct 2011 01:21:25 +0200
Quoting fbissey@...:

> Quoting rose@...:
>
>> The installation of scipy-0.9.0-r2 is blocked by sage-4.7.1-r2,
>> because 'emerge scipy' fails if numpy-1.5.1 and not numpy-1.6.1-r1 is
>> installed. But the installation of numpy-1.6.1-r1 is blocked by
>> sage-4.7.1-r2:
>>
>> root@impala:/root(2)# emerge -pvuDN world
>> These are the packages that would be merged, in order:
>> Calculating dependencies... done!
>> [ebuild     U  ] sci-libs/scipy-0.9.0-r2 [0.9.0-r1] USE="doc -umfpack" 0 kB
>> Total: 1 package (1 upgrade), Size of downloads: 0 kB
>> WARNING: One or more updates have been skipped due to a dependency conflict:
>> dev-python/numpy:0
>>   (dev-python/numpy-1.6.1-r1::gentoo, ebuild scheduled for merge)
>> conflicts with
>>     ~dev-python/numpy-1.5.1 required by
>> (sci-mathematics/sage-4.7.1-r2::sage-on-gentoo, installed)
>> dev-python/pexpect:0
>>   (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for
>> merge) conflicts with
>>     ~dev-python/pexpect-2.0 required by
>> (sci-mathematics/sage-4.7.1-r2::sage-on-gentoo, installed)
>>
>> The restriction to numpy-1.5.1 was motivated with missing clapack_*
>> symbols corresonding to Bug
>> https://bugs.gentoo.org/show_bug.cgi?id=371099.
>>
>> But this issue seems to be solved now, comment 40 to Bug 371099.
>
> I am not sure I understand your email fully. scipy-0.9.0-r2 doesn't require
> numpy-1.6.1.
> Indeed you cannot upgrade numpy to 1.6.1 but that doesn't prevent the
> merging of
> anything. It is just a version constraint. It is unfortunate but that's
> the way
> it is.
>
> Do you absolutely need numpy-1.6 for something else than sage?
>
> Francois

Hi Francois,

it seems, that scipy-0.9.0-r2 fails to emerge if numpy-1.5.1 is  
installed but it is emerged if numpy-1.6.1-r1, compare Bug 386269
https://bugs.gentoo.org/show_bug.cgi?id=386269 .

Regards Juergen




Replies:
Re: sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
-- fbissey
References:
sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
-- rose
Re: sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
-- fbissey
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
Next by thread:
Re: sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
Previous by date:
Re: sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
Next by date:
Re: sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1


Updated Jun 15, 2012

Summary: Archive of the gentoo-science mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.