Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-science
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-science@g.o
From: P Purkayastha <ppurka@...>
Subject: Re: sci-mathematics/sage-4.7.1 and numpy version
Date: Thu, 25 Aug 2011 18:31:30 +0800
On 08/25/2011 06:24 AM, fbissey@... wrote:
> Quoting Steven Trogdon <strogdon@...>:
>
>> On Wed, 24 Aug 2011 12:03:19 +0200
>> rose@... wrote:
>>
>>> Hi,
>>>
>>> I just installed more or less succesful sage. During the installation
>>> numpy was downgraded from numpy-1.6.1 to numpy-1.5.1.
>>> Now every 'emerge -uvDN world' complaines about;
>>>
>>> WARNING: One or more updates have been skipped due to a dependency
>>> conflict:
>>>
>>> dev-python/numpy:0
>>>
>>> (dev-python/numpy-1.6.1::gentoo, ebuild scheduled for merge)
>>> conflicts with
>>> ~dev-python/numpy-1.5.1 required by
>>> (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed)
>>>
>>> dev-python/pexpect:0
>>>
>>> (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for
>>> merge) conflicts with
>>> ~dev-python/pexpect-2.0 required by
>>> (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed)
>>>
>>> If I try to install couchdb, numpy-1.6.1 will be installed again:
>>>
>>> root@caiman:/root(4)# emerge -pvuDN couchdb
>>>
>>> These are the packages that would be merged, in order:
>>>
>>> Calculating dependencies... done!
>>> [ebuild N ] dev-lang/erlang-14.2.3 USE="doc emacs java odbc smp ssl
>>> tk wxwidgets -halfword -hipe -kpoll -sctp" 98,075 kB
>>> [ebuild N ] dev-db/couchdb-1.1.0 USE="-test" 1,063 kB
>>> [ebuild U ] dev-python/numpy-1.6.1 [1.5.1] USE="doc lapack -test" 0 kB
>>>
>>> Should I mask numpy-1.6.1 or how are the chances that sage will work
>>> with numpy-1.6.1?
>>>
>> At least until this Bug
>>
>> https://bugs.gentoo.org/show_bug.cgi?id=371099
>>
>> is resolved (sog) sage requires ~numpy-1.5.1
>>
>> I'm not sure exactly the impact on your system of masking
>> >=numpy-1.6.0 but you
>> could try that and see what emerge -puDNv world gives. I don't see which
>> component, if any, of couchdb is pulling in numpy or where else numpy is
>> needed on your system. Oh, and you will also have to mask >=pexpect-2.4
>>
> Hi all,
>
> Sorry I needed to have a little break. numpy-1.6+ is not compatible with
> sage
> at the moment:
> http://trac.sagemath.org/sage_trac/ticket/11334
> so don't try it. I suspect numpy wants to upgrade to 1.6.1 for you for the
> following reason:
> 1) you put numpy in your package.keywords file
> 2) numpy is part of your world set. It is upgraded independently of any
> dependency requirement. The fact that it is pulled just by -D is
> somewhat a bug
> in portage - although there could be a web of dependencies leading to
> numpy.
> emerge -puNv couchdb probably won't pick it.
>
> If you downgraded from numpy-1.6.x to 1.5.1 don't forget to rebuild scipy.
>
> Francois
>

I think it is a limitation of portage, in that it doesn't do reverse 
dependency checking every time you upgrade a package by its name.

~> emerge -p numpy

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-python/numpy-1.6.0 [1.5.1]
~> emerge -p numpy sage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-python/numpy-1.5.1
[ebuild   R   ~] sci-mathematics/sage-4.7.1

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-python/numpy:0

   (dev-python/numpy-1.6.0::gentoo, ebuild scheduled for merge) 
conflicts with
     ~dev-python/numpy-1.5.1 required by 
(sci-mathematics/sage-4.7.1::sage-on-gentoo, ebuild scheduled for merge)

~> emerge -pu numpy sage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-python/numpy-1.6.0 [1.5.1]
~> emerge -puD numpy sage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/pam-0

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-python/numpy:0

   (dev-python/numpy-1.6.0::gentoo, ebuild scheduled for merge) 
conflicts with
     ~dev-python/numpy-1.5.1 required by 
(sci-mathematics/sage-4.7.1::sage-on-gentoo, installed)

~>



References:
sci-mathematics/sage-4.7.1 and numpy version
-- rose
Re: sci-mathematics/sage-4.7.1 and numpy version
-- Steven Trogdon
Re: sci-mathematics/sage-4.7.1 and numpy version
-- fbissey
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: sci-mathematics/sage-4.7.1 and numpy version
Next by thread:
More than 200 hundred errors in testsuite
Previous by date:
Re: sci-mathematics/sage-4.7.1 and numpy version
Next by date:
Re: sci-mathematics/sage-4.7.1 and numpy version


Updated Jul 05, 2012

Summary: Archive of the gentoo-science mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.