Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-science
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: <gentoo-science@g.o>
From: Christopher Schwan <cschwan@...>
Subject: Re: tachyon-0.98.9-r1 fails to install due to wrong USE flags
Date: Mon, 22 Aug 2011 10:02:40 +0200
On Sunday 21 August 2011 19:21:23 rose@... wrote:
> Quoting rose@...:
> > I try to install [sage-on-gentoo] sage. I come until tachyon.
> > 
> > 'emerge tachyon' fails with:
> >>>> Emerging (3 of 20) media-gfx/tachyon-0.98.9-r1
> >  
> >  * tachyon-0.98.9.tar.gz RMD160 SHA1 SHA256 size ;-) ...
> >  
> >                                        [
> >                                        
> >                                        o
> >                                        k
> >                                        
> >                                        ]
> >  
> >  * ERROR: media-gfx/tachyon-0.98.9-r1 failed (setup phase):
> >  *   tachyon does not support MPI with OpenGL and threads
> > 
> > openmpi was installed with "cxx fortran ipv6 romio threads" USE flags.
> 
> > There is no OpenGL USE flag for openmpi:
> I have now removed the threads USE flag from openmpi, but 'emerge
> tachyon' still fails with the same error:
> 
> root@caiman:/root(26)# emerge -vuND sage
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [ebuild  N     ] media-gfx/tachyon-0.98.9-r1  USE="doc examples jpeg
> mpi opengl png threads" 0 kB [0]
> [ebuild  N     ] dev-python/twisted-mail-11.0.0  0 kB [0]
> ...
> 
> >>> Emerging (1 of 18) media-gfx/tachyon-0.98.9-r1
> 
>   * tachyon-0.98.9.tar.gz RMD160 SHA1 SHA256 size ;-) ...
> 
>                                             [ ok ]
>   * ERROR: media-gfx/tachyon-0.98.9-r1 failed (setup phase):
>   *   tachyon does not support MPI with OpenGL and threads
> ...
> root@caiman:/root(27)# emerge -pvD openmpi
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [ebuild   R    ] sys-cluster/openmpi-1.5.3-r2  USE="cxx fortran ipv6
> romio -heterogeneous -infiniband -mpi-threads -pbs -sctp -slurm
> -threads -vt" 0 kB

Hi,

you have to find a combination of USE flags which work together. In your case, I 
suggest removing the mpi flag and keeping the opengl and threads flags. This 
will enable accelerated rendering with OpenGL and threads - which will not 
work with the Message Passing Interface (MPI).

When I wrote the tachyon ebuild it was not easily possible to define a valid 
combination of USE-flags and I have to admit the current solution is not the 
best. I think with EAPI=4 it should be possible to find a better approach.

Cheers,
Christopher



Replies:
Re: tachyon-0.98.9-r1 fails to install due to wrong USE flags
-- rose
References:
tachyon-0.98.9-r1 fails to install due to wrong USE flags
-- rose
Re: tachyon-0.98.9-r1 fails to install due to wrong USE flags
-- rose
Navigation:
Lists: gentoo-science: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: tachyon-0.98.9-r1 fails to install due to wrong USE flags
Next by thread:
Re: tachyon-0.98.9-r1 fails to install due to wrong USE flags
Previous by date:
Re: Can not run sage-notebook
Next by date:
Re: Can not run sage-notebook


Updated Jul 05, 2012

Summary: Archive of the gentoo-science mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.