Gentoo Archives: gentoo-security

From: pb <pb@××××××××××.pl>
To: gentoo-security@l.g.o
Subject: Re: [gentoo-security] new kernel vulnerability in 2.2, 2.4 and 2.6 series
Date: Tue, 06 Jan 2004 06:29:51
Message-Id: 3FFA5554.7040309@kielce.msk.pl
In Reply to: [gentoo-security] new kernel vulnerability in 2.2, 2.4 and 2.6 series by Tobias Weisserth
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Tobias Weisserth wrote:
> Hello everybody, > > there is a new kernel vulnerability in the mremap system call. This > affects all kernels of the 2.2, 2,4 and 2.6 series with the exception of > 2.4.24. There is some information on this at > http://isec.pl/vulnerabilities/isec-0013-mremap.txt. >
Here's a hotfix from Wojtek Kaniewski for <=2.4.23 kernels # wget http://toxygen.net/hotfixes/mremap.c # gcc -Wall -O3 -fomit-frame-pointer -I/usr/src/linux/include -c -o mremap.o mremap.c # insmod mremap.o pb PS. gentoo-security doesn't have "Reply-To: gentoo-security@l.g.o" so i accidentally sent the yesterdays' answer to Tobias only. - -- Public Key: http://teleinfo.tu.kielce.pl/~pb/gpg.asc -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.3 (GNU/Linux) iD8DBQE/+lVTTE0TNzgUY2sRAq4fAKDHehiYVpSOLI4435bsqidVygKBJACgxFWW Mahk3BIPWjrBE59Vj1ptrCw= =IP4U -----END PGP SIGNATURE----- -- gentoo-security@g.o mailing list

Replies

Subject Author
Re: [gentoo-security] new kernel vulnerability in 2.2, 2.4 and 2.6 series Tobias Weisserth <tobias@×××××××××.de>