Gentoo Archives: gentoo-security

From: "Stéphane Joguet" <sjoguet@×××.fr>
To: gentoo-security@l.g.o
Subject: RE: [gentoo-security] invalid section : "db"
Date: Thu, 26 Jan 2006 09:18:11
Message-Id: 003401c62258$a1215320$6f01850a@sjoguet1
In Reply to: [gentoo-security] invalid section : "db" by Robert Larson
Hello,

Could you send us the command line you typed ?

Thanks

-----Message d'origine-----
De : Robert Larson [mailto:robert@×××××××××.com] 
Envoyé : mercredi 25 janvier 2006 22:10
À : gentoo-security@l.g.o
Objet : [gentoo-security] invalid section : "db"

Hello,

I'm trying to setup Prelude IDS on a new server and I seem to be running
into 
problems with prelude-manager upon startup.  It does 
start but it does not connect to MySQL (maybe I'm wrong and it's 
libpreludedb).  
I have the following versions installed:

prelude-manager-0.9.1-r1
libprelude-0.9.3
libpreludedb-0.9.2

Here are the errors I receive when running "prelude-manager" from the
command 
line:

/etc/prelude-manager/prelude-manager.conf:90: invalid section : "db".
/etc/prelude-manager/prelude-manager.conf:93: invalid option "type" in 
"global" section at depth 0.
/etc/prelude-manager/prelude-manager.conf:96: invalid option "host" in 
"global" section at depth 0.
/etc/prelude-manager/prelude-manager.conf:99: invalid option "port" in 
"global" section at depth 0.
/etc/prelude-manager/prelude-manager.conf:102: invalid option "name" in 
"global" section at depth 0.
/etc/prelude-manager/prelude-manager.conf:108: invalid option "pass" in 
"global" section at depth 0.
- server started (listening on 0.0.0.0 port 4690).


Here is my configuration located in
/etc/prelude-manager/prelude-manager.conf:
include = /etc/prelude/default/global.conf
listen = 0.0.0.0
[db]
type = mysql
host = localhost
port = 3306
name = prelude
user = prelude
pass = *cough!* you wish *cough!*

The contents of the included global.conf are:
[prelude]


Could I be missing something?  When I first set it up I just went through
and 
uncommented the items above, so I wouldn't think that it wouldn't be able to

recognize "[db]" as a valid section.


Any ideas on how I could troubleshoot this further would be, oh, so helpful.


Thanks in advance!


Robert Larson

-- 
gentoo-security@g.o mailing list


-- 
gentoo-security@g.o mailing list

Replies

Subject Author
Re: [gentoo-security] invalid section : "db" Robert Larson <robert@×××××××××.com>