Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-security
Navigation:
Lists: gentoo-security: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-security@g.o
From: Gustavo Adolfo Silva Ribeiro Felisberto <humpback@...>
Subject: Gcc version on affected kernels. Was: The brk() overflow
Date: Thu, 4 Dec 2003 21:40:34 +0000
I have a machine running 2.4.21_pfeifer-r1_pre3 with grsec activated
(big kernel, no modules support) and the "exploit" build ok with both
nasm  0.98.38 and 0.98.34, but with both versions when i tried to run
it:
humpback@www humpback $ ./a.out 
Segmentation fault

and in messages:
PAX: From 192.168.1.235: task a.out:11228, uid/euid: 5005/5005, may have
attempted to execute invalid code at 00001ead

This machine is a old gentoo 1.1 release (gcc version 2.95.3 20010315
(release)). Any ideas if it is related?

-- 
Gustavo Felisberto
(HumpBack)
------------
It's most certainly GNU/Linux, not Linux. Read more at
http://www.gnu.org/gnu/why-gnu-linux.html .
-------------
Attachment:
pgpwj36bFmEru.pgp (PGP signature)
Navigation:
Lists: gentoo-security: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
test
Next by thread:
MD5 mismatch for XFree86 patch
Previous by date:
test
Next by date:
MD5 mismatch for XFree86 patch


Updated Jun 17, 2009

Summary: Archive of the gentoo-security mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.