Gentoo Archives: gentoo-sparc

From: Paul Heinlein <heinlein@××××××.com>
To: Gentoo Sparc List <gentoo-sparc@l.g.o>
Subject: Re: [gentoo-sparc] Sendmail AUTH breaks with cyrus-sasl-2.1.18-r2
Date: Fri, 08 Oct 2004 20:11:49
Message-Id: Pine.LNX.4.60.0410081308420.3003@localhost.localdomain
In Reply to: Re: [gentoo-sparc] Sendmail AUTH breaks with cyrus-sasl-2.1.18-r2 by Christian Birchinger
On Fri, 8 Oct 2004, Christian Birchinger wrote:

> On Thu, Oct 07, 2004 at 09:18:33AM -0700, Paul Heinlein wrote: >> I emerged cyrus-sasl-2.1.18-r2 this morning per GLSA 200410-05. >> Sendmail no longer advertises or accepts any AUTH mechanisms. It >> had been working just fine under 2.1.14, but now I can't re-emerge >> 2.1.14 because the build process exits with a compiler error. >> >> Ack! >> >> Did something change between 2.1.14 and 2.1.18 that I'm missing? > > I just installed dev-libs/cyrus-sasl-2.1.19-r1 on my sparc64 machine > and i was able to authenticate with smtp auth on sendmail. But well, > the older 2.1.18 also worked. I use saslauthd with pam. > > My config files are: > > # cat /etc/sasl2/Sendmail.conf
Yeah, I had already figured out that this was the problem. I had been running 2.1.14, which looked for Sendmail.conf in /usr/lib/sasl2. Once I copied it to /etc/sasl2 and restarted sendmail, things worked again. Thanks! -- Paul Heinlein <heinlein@××××××.com> -- gentoo-sparc@g.o mailing list