Gentoo Archives: gentoo-sparc

From: Ferris McCormick <fmccor@g.o>
To: gentoo-sparc@l.g.o
Subject: Re: [gentoo-sparc] xorg device problems
Date: Tue, 13 Sep 2005 17:47:18
Message-Id: 1126633612.1797.6.camel@polylepis.inforead.com
In Reply to: [gentoo-sparc] xorg device problems by Jason Williams
On Tue, 2005-09-13 at 11:40 -0500, Jason Williams wrote:
> Alright, I've posted this in the forum without response and I can't > seem to google anything useful. I have an U60 w/ two Creator3D cards; > I had these cards setup running xinerama just great about a year ago > when I had gentoo on this box the first time. However, now that I've > since reinstalled, xorg can't seem to differentiate the two cards. I'm > using the exact same configuration that worked a year ago. The > relevant part of my xorg.conf is: > > Section "Device" > Identifier "Card0" > Driver "sunffb" > BusID "SBUS:fb0" > VendorName "Sun Microsystems" > BoardName "Sun|FFB2+ Vertical Creator 3d (ffb)" > EndSection > > Section "Device" > Identifier "Card1" > Driver "sunffb" > BusID "SBUS:fb1" > VendorName "Sun Microsystems" > BoardName "Sun|FFB2+ Vertical Creator 3d (ffb)" > EndSection > > This section of configuration generates the following errors in my log: > > (II) SUNFFB: driver for Creator, Creator 3D and Elite 3D > (WW) SUNFFB: More than one matching Device section for instance > (BusID: Card0) found: SBUS:fb0 > (WW) SUNFFB: No matching Device section for instance (BusID > SBUS:/SUNW,ffb@1d,0) found >
This is more of a question than an answer. (1) Have you changed kernels? (2) Have you tried making your BusID conform to what xorg's log reports finding? It sees them both, but doesn't like how you are identifying them. Two simple experiments: (1) Comment out the BusID lines and see what xorg says; use SBUS:fb0 for both busid lines, since xorg is seeing two devices at fb0. I realize this is not much of a response, but it might give you a couple ideas until someone who knows more than I do answers, too.
> A full listing of both of the latter files can be seen at > http://forums.gentoo.org/viewtopic-t-379687.html . Thanks in advance > to anyone who can shed any light onto what's going on here. > > - jbw >
-- Ferris McCormick (P44646, MI) <fmccor@g.o> Developer, Gentoo Linux (Sparc, Devrel)

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-sparc] xorg device problems Jason Williams <jason.b.williams@×××××.com>