Gentoo Archives: gentoo-sparc

From: Will Simoneau <simoneau@×××××××.edu>
To: gentoo-sparc@l.g.o
Subject: Re: [gentoo-sparc] alsa sound do not work on Ultrasparc 5
Date: Tue, 19 Dec 2006 14:41:09
Message-Id: 20061219144034.GB17375@ele.uri.edu
In Reply to: [gentoo-sparc] alsa sound do not work on Ultrasparc 5 by "张韡武"
On 22:42 Mon 18 Dec     , ????????? wrote:
> * To be straightforward: System behaviour: > > sappho # amixer > amixer: Mixer attach default error: No such file or directory > sappho # mpg321 -o alsa 1.Allegro.mp3 > High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2, and 3. > Version 0.59q (2002/03/23). Written and copyrights by Joe Drew. > Uses code from various people. See 'README' for more! > THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR OWN RISK! > Title : Horowitz plays Tchaikovsky & B Artist: Beethoven > Album : Tchaikovsky: Concerto No.1/Bee Year : 1990 > Comment: Horowitz/Reiner/Toscanini Genre : Classical > > Playing MPEG stream from 1.Allegro.mp3 ... > MPEG 1.0 layer III, 128 kbit/s, 44100 Hz joint-stereo > ALSA lib confmisc.c:558:(snd_determine_driver) could not open control for card 0 > ALSA lib conf.c:2712:(snd_config_hooks_call) function snd_config_hook_load_for_all_cards returned error: No such file or directory > ALSA lib pcm.c:2014:(snd_pcm_open_conf) Invalid type for PCM default definition (id: default, value: cards.pcm.default) > ALSA snd_pcm_open error: Invalid argument > Can't find a suitable libao driver. (Is device in use?) > > > What I have tried to get this problem solved: > > == check dmesg == > dmesg shows: > [ 26.551490] Advanced Linux Sound Architecture Driver Version > 1.0.12rc1 (Thu Jun 22 13:55:50 2006 UTC). > [ 26.986597] ALSA device list: > [ 27.108836] #0: Sun CS4231 at 0x1fff1200000, irq 10 > > Also > sappho snd # dmesg | grep snd > [ 5250.225152] I7: <snd_pcm_lib_write_transfer+0x9c/0xc8> > [ 5250.225172] Caller[0000000000613078]: snd_pcm_lib_write_transfer+0x9c/0xc8 > [ 5250.225204] Caller[00000000006133a4]: snd_pcm_lib_write1+0x300/0x43c > [ 5250.225235] Caller[0000000010026750]: snd_pcm_oss_sync+0x170/0x27c [snd_pcm_oss] > [ 5250.225307] Caller[00000000100271e4]: snd_pcm_oss_release+0x24/0x9c [snd_pcm_oss] > > > == check /etc/dev == > No node with major ID = 116 exist in /etc/dev/ > > Try: > sappho /dev # MAKEDEV > no new node with major ID 116 created; > try > sappho /dev # MAKEDEV update > /usr/sbin/MAKEDEV: don't know what "alsa" is > /usr/sbin/MAKEDEV: don't know what "usb_device" is > > My uname -a > sappho dev # uname -a > Linux sappho.realss.com 2.6.18-gentoo-r3 #11 Sun Dec 17 07:14:29 HKT > 2006 sparc64 sun4u TI UltraSparc IIi (Sabre) GNU/Linux > > Please point out my mistake. Thanks a lot!
Your kernel dumped stack and part of it is showing in your dmesg fragment... please post the rest of that info, because it very likely will help in figuring out what's wrong.

Replies

Subject Author
Re: [gentoo-sparc] alsa sound do not work on Ultrasparc 5 "张韡武" <zhangweiwu@××××××.com>