Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-sparc
Navigation:
Lists: gentoo-sparc: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-sparc@g.o
From: brant williams <brant@...>
Subject: Re: Booting the system...
Date: Thu, 27 Mar 2008 14:32:09 -0500 (CDT)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256


Hi Ben,

Good about #1.  There's actually a lot of good information on the www 
about OpenBoot.

As for #2, what does your silo.conf look like?  In my experience <which 
doesn't involve genkernel>, an initrd isn't required.  Can you boot the 
box from the install disc and check out the current kernel config?  I'd 
say disable initrd and any references to it (and make sure that you're not 
loading disk controllers as modules), and then make sure silo.conf isn't 
trying to boot from one.

For #3, are you using the PROM framebuffer as well as the ATI (aty) one? 
Maybe toggling the PROM framebuffer console is the solution...

Here's the relevant snippet from my Ultra 10's kernel config; hope that 
helps a little:

#
# Console display driver support
#
# CONFIG_PROM_CONSOLE is not set
CONFIG_DUMMY_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y
# CONFIG_FRAMEBUFFER_CONSOLE_ROTATION is not set
CONFIG_FONTS=y
# CONFIG_FONT_8x8 is not set
# CONFIG_FONT_8x16 is not set
# CONFIG_FONT_6x11 is not set
# CONFIG_FONT_7x14 is not set
# CONFIG_FONT_PEARL_8x8 is not set
# CONFIG_FONT_ACORN_8x8 is not set
CONFIG_FONT_SUN8x16=y
# CONFIG_FONT_SUN12x22 is not set
# CONFIG_FONT_10x18 is not set
CONFIG_LOGO=y
# CONFIG_LOGO_LINUX_MONO is not set
# CONFIG_LOGO_LINUX_VGA16 is not set
# CONFIG_LOGO_LINUX_CLUT224 is not set
CONFIG_LOGO_SUN_CLUT224=y
# CONFIG_FB_SPLASH is not set


brant williams
FCAA CDCA 20BC 3925 D634  F5C4 7420 6784 4DEB 6002



On Wed, 26 Mar 2008, BRM wrote:

> Date: Wed, 26 Mar 2008 14:39:09 -0700 (PDT)
> From: BRM <bm_witness@...>
> Reply-To: gentoo-sparc@g.o
> To: gentoo-sparc@g.o
> Subject: Re: [gentoo-sparc] Booting the system...
> 
> Figured it out. I could have either adjusted the NVRAM setting for the 'disk' or move the Hard drive to the other slot (which is what I did).
>
> Still running into problems with the boot process though - this solves #1.  However, #2 is still a big issue. It doesn't seem to be finding a valid initrd image. Shouldn't genkernel have built a valid one to install?
>
> TIA,
>
> Ben
>
> ----- Original Message ----
> From: Benjamen R. Meyer <bm_witness@...>
> To: gentoo-sparc@g.o
> Sent: Monday, March 24, 2008 3:57:19 PM
> Subject: [gentoo-sparc] Booting the system...
>
> I got the system installed, and everything seems to be okay with three
> exceptions:
>
> 1) I have to run "boot disk1:1" at the PROM prompt to get the system to
> boot. I assume I can set that into the PROM, just like I set the cdrom
> to be what is boot, no? If not, how do I resolve that? FYI - In case it
> matters, I did accidentally delete the #3 partition during the
> partitioning, but recreated it using the 's' command in fdisk.
>
> 2) Just before #3 happens, I notice a message from the kernel stating it
> can't find the initrd image located in /boot - generated by genkernel. I
> didn't setup a _separate_ boot partition, but that shouldn't be an issue
> for SILO should it?
>
> 3) The system loads the kernel, which runs a little, then switches vid
> modes and blanks - it doesn't return to the screen like the 2007.0 2617
> does when the atyfb is not disabled, it just blanks, and dies per #2.
> Using 'video=atyfb:off' resolves this and reveals the messages. I'd
> really like to be able to not have to use 'atyfb:off' as it really hurts
> the eyes the way it reprints the screen all the time for the littlest
> line movement. Any recommendations? (I could live with it if I
> absolutely had to.)
>
> FYI - after #3 the system completely hangs, and despite the message
> about STOP+A, it doesn't work until I completely cycle the power the
> system - no return to the PROM; the soft-power button _does_ work for this.
>
> TIA,
>
> Ben
>
> -- 
> gentoo-sparc@g.o mailing list
>
>
>
>
> -- 
> gentoo-sparc@g.o mailing list
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)

iD8DBQFH6/Y9dCBnhE3rYAIRCHb4AJ0R59FLMqqMNCgr9jHnUXpdj6jyjACglKgx
kG1hd6G1qG94l0M+Oynru4c=
=sL1p
-----END PGP SIGNATURE-----
-- 
gentoo-sparc@g.o mailing list


References:
Re: Booting the system...
-- BRM
Navigation:
Lists: gentoo-sparc: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Booting the system...
Next by thread:
Re: Booting the system...
Previous by date:
Re: Booting the system...
Next by date:
Re: Booting the system...


Updated Jun 17, 2009

Summary: Archive of the gentoo-sparc mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.