Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-sparc
Navigation:
Lists: gentoo-sparc: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-sparc@g.o
From: gentuxx <gentuxx@...>
Subject: Re: Snort?
Date: Sun, 06 Aug 2006 17:18:26 -0700
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jason Wever wrote:
> On Sun, 06 Aug 2006 15:28:13 -0700
> gentuxx <gentuxx@...> wrote:
>
>> So, if I wanted to *test it* and/or live with restarting it once a
>> day, how do I unmask it so emerge will install it?
>> (/etc/portage/package.keywords didn't work)
>
> NOTE: The advice given below is not recommended for working around
> packages that are masked or lack sparc keywords.  Specifically, if an
> ebuild has a -sparc keyword, it is known the software is broken.
>
Understood and accepted.  ;-)
> Chances are you didn't do it quite right.  You'll probably want an
> entry like "net-analyzer/snort ~x86" in package.keywords.  If I add
> this to /etc/portage/package.keywords on a sparc system with stable
> keywords, I can now emerge snort-2.4.5.
>
> Cheers,
Putting "~x86" in package.keywords still gets me this:

jupiter portage # emerge -pv snort

These are the packages that would be merged, in order:

Calculating dependencies
!!! All ebuilds that could satisfy "snort" have been masked.
!!! One of the following masked packages is required to complete your
request:
- - net-analyzer/snort-2.6.0 (masked by: package.mask)
# Marcelo Goes <vanquirius@g.o> (07 Jul 2006)
# Masked for testing
# Please see bug 136250 for more details

- - net-analyzer/snort-2.4.5 (masked by: -sparc keyword)

For more information, see MASKED PACKAGES section in the emerge man
page or
refer to the Gentoo Handbook.

But putting '-sparc' seems to work:

jupiter portage # emerge -av snort

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] net-libs/libpcap-0.9.4  USE="-ipv6" 415 kB
[ebuild  N    ] dev-libs/libpcre-6.3  USE="-doc" 552 kB
[ebuild  N    ] net-analyzer/snort-2.4.5  USE="ssl -flexresp -inline
- -mysql -odbc -postgres -prelude -sguil -snortsam" 3,540 kB

Total size of downloads: 4,508 kB

Would you like to merge these packages? [Yes/No]


- --
gentux
echo "hfouvyyAhnbjm/dpn" | perl -pe 's/(.)/chr(ord($1)-1)/ge'

gentux's gpg fingerprint ==> 5495 0388 67FF 0B89 1239  D840 4CF0 39E2
18D3 4A9E
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFE1obSTPA54hjTSp4RAmOcAJ4vppYK/U6tMWBnNE7emA/jYGodxgCfQVOa
iLPvuDCyKu4Dko5A0orS1D0=
=IBdR
-----END PGP SIGNATURE-----

-- 
gentoo-sparc@g.o mailing list


References:
Snort?
-- gentuxx
Re: Snort?
-- Mike Owen
Re: Snort?
-- gentuxx
Re: Snort?
-- Jason Wever
Navigation:
Lists: gentoo-sparc: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Snort?
Next by thread:
xorg-x11-7.1 (X-modular) is stable on sparc and in sync with x86.
Previous by date:
Re: Snort?
Next by date:
Re: Help with Gentoo on E4500


Updated Jun 17, 2009

Summary: Archive of the gentoo-sparc mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.