Gentoo Archives: gentoo-user-br

From: Renata Romanazzi <natzilla@×××××.com>
To: gentoo-user-br@l.g.o
Subject: Re: [gentoo-user-br] nvidia no gentoo não cria os nodes em /dev
Date: Thu, 15 Sep 2005 21:01:05
Message-Id: b5c411820509151400463a230@mail.gmail.com
In Reply to: Re: [gentoo-user-br] nvidia no gentoo não cria os nodes em /dev by Rodolfo Penha
Oi, Rodolfo. Eu estou com o kernel 2.6.13, que não tem mais suporte a
devfs. Eu tenho as linhas alias no /etc/modules.d/nvidia e verifiquei
que no arquivo de regras do udev também tem o nvidia, mas os devices
não são criados quando se carrega o modulo.

Não cheguei a criar os devices na mão porque acho que o udev deveria
fazer isso sozinho, então estou tentando fazer com que o udev tome
vergonha e faça seu trabalho.

On 9/15/05, Rodolfo Penha <rodolfo.penha@×××××.com> wrote:
> Bem, não sei se alguém tentou seguir as minhas dicas, mas vão ai > novamente... > > Dê uma olhada no /etc/modules.d/nvidia e veja se contém as linhas: > > alias char-major-195 nvidia > alias /dev/nvidiactl char-major-195 > > Se não estiverem lá, adicione e dê um modules-update. Veja se funciona. > > Caso ainda não funcione, crie os nodes da seguinte forma: > > mknod /dev/nvidiactl c 195 255 > mknod /dev/nvidia0 c 195 0 > chown root:video /dev/nvidia{ctl,0} > chmod 0660 /dev/nvidia{ctl,0} > > Adicione os usuários que vc queira que tenham aceleração gráfica no > grupo video. > > Creio que isto resolva. > > OBS: Meu RC_DEVICE_TARBALL está como "no" > > Outro detalhe: compilei o kernel com suporte a devfs: > > rodolfo modules.d # zcat /proc/config.gz |grep DEVFS > CONFIG_DEVFS_FS=y > # CONFIG_DEVFS_MOUNT is not set > # CONFIG_DEVFS_DEBUG is not set > > Porém desabilito no grub.conf e habilito o udev: > > title Gentoo Linux (Gentoo 2.6.12-gentoo-r6 - Framebuffer) > root (hd0,0) > kernel (hd0,0)/kernel-genkernel-x86-2.6.12-gentoo-r6 udev > root=/dev/hda5 video=vesafb:ypan,1024x768-32@85 gentoo=nodevfs > > > Se alguém, obtiver sucesso com estas dicas, por favor, envie um > "feedback" para a lista. > > [ ]s > > Rodolfo Penha > > -- > gentoo-user-br@g.o mailing list > >
-- Renata Rocha http://renata.org 7409917@ICQ | saavik@××××××.org renata@××××××××××××.net -- gentoo-user-br@g.o mailing list

Replies

Subject Author
Re: [gentoo-user-br] nvidia no gentoo não cria os nodes em /dev Rodolfo Penha <rodolfo.penha@×××××.com>
Re: [gentoo-user-br] nvidia no gentoo não cria os nodes em /dev Magno Torres <magnotorres@×××××.com>