Gentoo Archives: gentoo-user-br

From: "João Matos" <jaoneto@×××××.com>
To: gentoo-user-br@l.g.o
Subject: Re: [gentoo-user-br] Problema com downgrade do gcc
Date: Sun, 20 Nov 2011 20:55:37
Message-Id: CAP4tJZ+pfy6T3sqje5B1dPyDSXKmaUoRrwJbuo5p_Bpke-+bCQ@mail.gmail.com
In Reply to: Re: [gentoo-user-br] Problema com downgrade do gcc by Daniel da Veiga
> > Minha pergunta é, qual o motivo de usar o GCC que você precisa para > desenvolver como global do sistema? Isso pode causar quebras gerais, visto > que alguns programas podem reclamar de partes núcleo do sistema (glibc)
que
> foram compiladas ou ainda dependem, ou estão linkadas com versões mais > novas. > > Pq não deixar seu sistema rodando no 4.5 e criar um ambiente para > desenvolver no 4.4 (um eselect antes deve resolver, quem sabe até um
CHROOT)
> e voltar no final (se você quiser por exemplo atualizar o sistema). Quando > eu tinha o QEMU que dependia de uma versão ancestral do GCC e quando usava > cross-compiler eu fazia assim... YMMV.
Na verdade eu fiz um teste rápido, mudando o gcc ppra versão 4.4 usando o gcc-config, e ao abrir o qtcreator eu obtive aquele erro. Recompilei e não resolveu, então eu pensei em recompilar o sistema todo. :P Mas não resolveu. Depois de tudo recompilado e depois de removido o gcc 4.5, recompilei o firefox, e ele passou a funcionar normalmente, porém o qt-creator e chromiun nada... "fix_libtool_files.sh 4.4 && fix_libtool_files.sh 4.5" não resolveu. será q se eu apagar os arquivos listados abaixo e rodar um revdep-rebuild e resolvo, ou vou ter mais problemas do q ja tenho? * locate libstdc++ | grep -v win | grep -v share | grep -v portage* /usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.a /usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so /usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so.6 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so.6.0.13 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/32/libstdc++.a /usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/32/libstdc++.so /usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/32/libstdc++.so.6 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/32/libstdc++.so.6.0.13 -- João de Matos Linux User #461527 Graduando em Engenharia de Computação 2005.1 UEFS - Universidade Estadual de Feira de Santana