Gentoo Archives: gentoo-user-br

From: "João Matos" <jaoneto@×××××.com>
To: gentoo-user-br <gentoo-user-br@l.g.o>
Subject: [gentoo-user-br] como gerenciar múltiplas placas de áudio no kde/alsa?
Date: Wed, 17 Aug 2011 23:35:58
Message-Id: CAP4tJZ+CyxJ_DxCz6Whrj+s8__17Vcd_G8fvuFmLFW+jAojfeQ@mail.gmail.com
Caros,

Comprei uma webcan usb que vem com microfone, e isso tem se mostrado um
problema!

O amarok e os sons do kde funcionam normalmente, basta deixar o phonon
configurado. Porém o mplayer, vcl, kaffeine, e quaisquer outras coisas que
produzam som fora do kde estão se perdendo (emesene...).

procurei alguns artigos, e usei o "aplay -l" para obter o id da minha placa
de audio (on-board intel) e colocar em /etc/asound.conf. Mas isso não
funciona, talvez pq o id das placas fique (lamentávelmente) mudando. Outra
coisa interessante é que cada vez q eu reinicio o sistema (e eu já fiz isso
várias vezes hj) o kd me informa q determinados dispositivos de áudio foram
permanentemente removidos, eu os excluo, mas não vejo nenhum diferença. É
como se os mesmo dispositivos fossem identificados de maneira diferente a
cada vez q eu reinicio a máquina. 0.o

Tem como fazer tudo no sistema usar o phonon, ou configurar o alsa
devidamente?

Já tive problemas parecidos antes quando eu usava uma placa de audio off, e
resolvi de uma maneira bem simples: compilei o kernel sem o módulo da placa
onboard. Mas gostaria de gerenciar isso melhor agora, já q os 3 dispositivos
q o sistema reconhece são: a placa onboard da intel, a da nvidia (hdmi) e a
webcam, e eu quero usar as 3.

konoha shaka # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
konoha shaka # cat /etc/asound.conf
pcm.!default {
    type hw
    card 0
}
ctl.!default {
    type hw
    card 0
}

Att,

-- 
João de Matos
Linux User #461527
Graduando em Engenharia de Computação 2005.1
UEFS - Universidade Estadual de Feira de Santana

Replies

Subject Author
Re: [gentoo-user-br] como gerenciar múltiplas placas de áudio no kde/alsa? yermandu <yermandu@×××××.com>