Gentoo Archives: gentoo-user-br

From: Thiago Nunes <thiagonunesrs@×××××.com>
To: gentoo-user-br@l.g.o
Subject: Re: Se foi a placa de rede; era Re: [gentoo-user-br] Usar config antiga para compilar kernel
Date: Mon, 11 Jul 2011 04:46:29
Message-Id: CAG21P7q7HPoEfujLv+oC6kXoebqNwNv7P3X2RiVXQ52SFi0WKA@mail.gmail.com
In Reply to: Se foi a placa de rede; era Re: [gentoo-user-br] Usar config antiga para compilar kernel by Cleverson Casarin Uliana
Em 10 de julho de 2011 17:26, Cleverson Casarin Uliana
<clcaul@×××××.com> escreveu:

> Obrigado Thiago pela resposta abaixo e a outra. Agora ao iniciar com o > kernel novo 2.6.38 não inicializou minha eth0 que é uma Intel 82562 10/100. > No 2.6.34 o driver era aquele para as placas 10/1000 PCI express, agora > terei de catar aqui o driver correto.....
É estranho e pouco provável que o nome do módulo tenha mudado. Para ter certeza de que issoaconteceu faça o seguinte: 1- De boot no kernel que funciona; 2- Rode lspci -k para mostrar o nome do driver; 3- Vá na configuração do kernel que funciona e ache a opção que habilita o driver que funciona, geralmente o help da opção diz o nome do módulo; 4- Vá na configuração do novo kernel e veja se a mesma opção existe e está habilitada; 5- De boot no novo kernel e rode lsmod para ver o módulo está carregado; 6- Rode lspci -k para ver o se o kernel reconheceu o driver e se mostra ele no "Kernel driver in use:". Se o driver de que tu fala é o e100 pode até ser que tenha mudado mesmo porque eu lembro que esse driver um dia se chamou eepro100, mas não sei quando isso mudou. []s -- thiago

Replies

Subject Author
Re: Se foi a placa de rede; era Re: [gentoo-user-br] Usar config antiga para compilar kernel Cleverson Casarin Uliana <clcaul@×××××.com>