Gentoo Archives: gentoo-user-br

From: Naira Kaieski <naira@××××××.br>
To: gentoo-user-br@l.g.o
Subject: Re: [gentoo-user-br] Cópia de um sistema para outro HD
Date: Sun, 07 Aug 2011 21:45:48
Message-Id: 4E3F076A.6030407@faccat.br
In Reply to: Re: [gentoo-user-br] Cópia de um sistema para outro HD by Raphael MD
Boa noite,

Inicializa a máquina com o LiveCD, faz um chroot no hd que tem o SO e a 
partição /boot e grava o grub novamente na MBR deste disco.

-----------------------> chroot na partição do SO, CUIDADO os comando 
abaixo vão variar de acordo com o seu particionamento.
	mount /dev/sda3 /mnt/gentoo
	mount /dev/sda2 /mnt/gentoo/boot/
	mount -t proc none /mnt/gentoo/proc
	mount -o bind /dev /mnt/gentoo/dev
	chroot /mnt/gentoo /bin/bash
	env-update
	source /etc/profile
	export PS1="(chroot) $PS1"

-----------------------> Gravar grub na mbr
- Ajustar grub.conf
- Gravar o grub na mbr dos discos, executar o comando "grub" no shell
	grub>
	grub> find /boot/grub/stage1
  		(hd0,0)
	grub> root (hd0,0)
	grub> setup (hd0)

Depois basta desmontar as partições montadas e reiniciar a máquina.

Atenciosamente,
Naira Kaieski
Nucleo de Internet/Redes - Faccat
Linux Professional Institute - LPI000223834

Em 7/8/2011 16:04, Raphael MD escreveu:
> Caros! > > Fiz como a maioria recomendou, efetuei a cópia do hd utilizando o comando rsync, funcionou bem, consegui manter meu diretório /home. > > Mas estou com um outro problema muito estranho. > > O GRUB, da o erro 15, durante o boot. > > Mas não há motivos para isso, pois na minha partição de boot, dev/sdb1 está tuda certa, há o arquivo da kernel, há o arquivo do grub. > > Eu já formatei esta partição, ja instalei o grub de novo, compilei o kernel, e sempre da o erro 15, conferi no device.map a ordem dos hd's e está tudo correto. > > Chequei no fdisk, se o dev/sdb1 era de boot e ele é. > > Este erro me pegou. Abs >