Gentoo Archives: gentoo-user-br

From: "João Matos" <jaoneto@×××××.com>
To: gentoo-user-br@l.g.o
Subject: Re: [gentoo-user-br] Problema de charset ao montar partição automaticamente
Date: Thu, 21 Jun 2012 19:25:49
Message-Id: CAP4tJZJibUKwL-4PhJX49Cy-GMZxrnTp1H-hEFgq95R8roGJMw@mail.gmail.com
In Reply to: Re: [gentoo-user-br] Problema de charset ao montar partição automaticamente by Daniel da Veiga
A montagem não dá certo quando é feita automaticamente, pelo kde/udev, sem
entrada no fds tab.

Eu tenho um hd externo, formatado em ntfs que consigo montar normalmente
quando coloco a seguinte linha no fstab:

*#/dev/sdc1              /media/hd_externo       ntfs-3g
defaults,locale=pt_BR.iso8859-1 0 0*

porém se essa linha estiver descomentada eu só consigo montar o disco na
mão, rodando mount /media/hd_externo, e se tiver encaixado ele primeiro.

Quando tem vários pendrives a coisa fica realmente ruim.

Pensei que eu poderia configurar o udev pra usar o iso8859-1, ou adicionar
essa opção ao 'default' do mount options, não encontrei como fazer nenhuma
das duas ainda.

Se eu não conseguir fazer nada disso, talvez eu possa colocar UUID no fstab
em vez de /dev/sd*. Isso não vai resolver, mas pelo menos melhora um pouco.


Em 21 de junho de 2012 12:50, Daniel da Veiga <danieldaveiga@×××××.com>escreveu:

> Antes de mais nada, como você está montando essas unidades externas? > Faz muito tempo que não uso genkernel, mas não creio que isso tenha > algo a ver com as montagens. > > 2012/6/20 João Matos <jaoneto@×××××.com>: > > Caros, > > > > no meu fstab eu especifico o charset das partições > (locale=pt_BR.iso8859-1), > > e tudo funciona perfeitamente bem. Porém, quando encaixo um pendrive ou > hd > > externo em ntfs ou fat, os caracteres especiais não são exibidos > > corretamente, e eu não posso criar/copiar arquivos ou pastas acentuados. > > Onde configuro essa montagem automática para identificar o charset? Uma > > configuração específica do udev? > > > > Tava olhando do guia de udev do Gentoo, e observei q eu não uso o > parâmetro > > --udev na geração do kernel através do genkernel. Será que seria isso? > Vou > > recompilar amanhã para ver isso... > > > > Grato, > > > > -- > > João de Matos > > Linux User #461527 > > Graduando em Engenharia de Computação 2005.1 > > UEFS - Universidade Estadual de Feira de Santana > > > > -- > Daniel da Veiga > >
-- João de Matos Linux User #461527 Graduando em Engenharia de Computação 2005.1 UEFS - Universidade Estadual de Feira de Santana

Replies

Subject Author
Re: [gentoo-user-br] Problema de charset ao montar partição automaticamente Daniel da Veiga <danieldaveiga@×××××.com>
Re: [gentoo-user-br] Problema de charset ao montar partição automaticamente Ricardo Montania <ricardo@×××××××××××××××.br>