Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-br
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-br@g.o
From: "Benigno B. Junior" <bbj@...>
Subject: Re: Portage pos-pane com alzheimer serio
Date: Fri, 16 Sep 2005 18:46:16 -0300
Tente instalar o gentoolkit do ebuild /usr/portage/app-portage/gentoolkit/gentoolkit-0.2.0.ebuild

Para evitar que o mesmo seja atualizado por outra versão, use outro SLOT (1, por exemplo).

Depois, tente:  qpkg -I -nc > /var/lib/portage/world

Parece-me que o qpkg foi substituído pelo equery, em versões mais atuais.

Por algum motivo, o  "regenworld" não coloca todos os arquivos instalados no sistema (+- system?) em /var/lib/portage/world:
"cat /var/lib/portage/world | wc -l", resultando em 499 pacotes;
"qpkg -I -nc | wc -l", resultando em 570 pacotes, o que eu realmente tenho.

Para buscar por atualização para todos os pacotes do sistema, uso "emerge `qpkg -I -nc` -Upv"

Há um certo tempo, notei que o "emerge world -Upv" não vasculhava por todos os pacotes instalados no sistema, ficando, assim, muitos pacotes desatualizados.

On Fri, 16 Sep 2005 15:23:04 -0300
"Pablo \"NatuNobilis\"" <natunobilis@...> wrote:

> Amigos, passei recentemente por uma pane no meu sistema de arquivos 
> raiz. Foi por erro meu, mas foi uma brecha ridícula que o sistema não 
> podia ter deixado. Explico depois.
> 
> Conseqüências do problema: perdi todo o meu /etc/conf.d (já resolvido), 
> e meu portage simplesmente acha que eu não tenho nenhum pacote instalado 
> (totalmente não resolvido). :(
> 
> Pois bem. Fora esse troço do portage, meu sistema está funcionando 
> perfeitamente, como antes. Não precisei reinstalar nada, exceto os 
> pacotes que tinham arquivos no /etc/conf.d.
> 
> Mas como é que eu faço pra informar ao portage que eu já tenho um MONTE 
> de pacotes instalados? O emerge --inject, que foi minha primeira 
> tentativa, informa que está "deprecated", e sugere a substituição pelo 
> /etc/portage/package.provided. Porém, o package.provided é diferente do 
> que eu preciso.
> 
> Tentei ver todos os pacotes instalados através do genlop -l, mas ele só 
> lista os pacotes instalados desde 2 de dezembro de 2004, sendo que meu 
> sistema é significativamente mais antigo que isso, e provavelmente tem 
> pacotes que não aparecem nos logs pós-2/12/2004.
> 
> E aí, alguém teria uma sugestão salvadora?
> 
> Abraços a todos,
> Pablo.
> 
> 
> PS: A explicação da falha no fs: Botei meu laptop pra dormir com o 
> comando 'sync && echo disk >/sys/power/state', e ele foi dormir muito 
> educadamente. Depois disso, lembrei que precisava ainda pegar um arquivo 
> no computador, e por isso liguei-o novamente. Por algum motivo, mandei 
> ele NÃO retornar do sono, ou seja, mandei ele ligar como se ele tivesse 
> sido desligado normalmente. Já fiz isso várias vezes e nunca tive problemas.
> Esta vez não foi diferente. Ele entrou normalmente no sistema. 
> Desliguei-o-o :)  sem botar pra dormir. Shutdown mesmo.
> Correu sem problema.
> 
> Na manhã seguinte, liguei o bicho como de costume. Ele ligou como se 
> tivesse acabado de voltar do sono! Funcionou direito, com alguns avisos 
> estranhos, como "terminal type blablalba not Linux", entre outros. Achei 
> que fosse pane passageira. Uma hora, ele se desligou sozinho. Deu medo.
> 
> Religuei-o-o :)  e ele foi entrando direito, até dizer que "filesystem 
> is NOT clean", e tentar limpar o fs. Deu mil mensagens de erro durante a 
> limpeza, e falou pra eu rodar o fsck (naquele esquema de "Type root 
> password for system maintenance or press ENTER for normal boot"). Deu 
> mais medo.
> 
> Usei um liveCD do gentoo pra dar um reiserfsck --check e reiserfsck 
> --rebuild-tree no fs raiz. Erros consertados (vários deles, 
> aparentemente), reiniciei pelo HD. Para minha surpresa, vários erros 
> aconteceram durante a inicialização (o /etc/conf.d tinha morrido), e o 
> portage esqueceu todo seu passado de instalações.
> 
> Essa é uma história verídica. Aconteceu comigo mesmo. :(
> -- 
> gentoo-user-br@g.o mailing list
> 


-- 
panic("%s: CORRUPTED BTREE OR SOMETHING", __FUNCTION__);
        linux-2.6.6/fs/xfs/xfs_bmap.c

Benigno B. Junior <bbj@...>, ICQ#112673
GPG KeyID: D3995B21
GPG Key: http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xD3995B21
Fingerprint: D3CC 92F7 42F8 8EA7 0EB3  F74B E401 B7E1 D399 5B21
PolarHome.com - Gateway to Freedom
FreeBSD/Ultrix Administration
 18:33:34 up 11:10,  3 users,  load average: 0.25, 0.21, 0.18
Attachment:
pgpebR8grtXmq.pgp (PGP signature)
References:
Portage pos-pane com alzheimer serio
-- Pablo \"NatuNobilis\"
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Portage pos-pane com alzheimer serio
Next by thread:
[OFF] Preciso trocar o e-mail da lista....
Previous by date:
Re: [OFF] Preciso trocar o e-mail da lista....
Next by date:
Re: Aviso (era -> Re: nvidia no gentoo n�cria os nodes em /dev)


Updated Jun 17, 2009

Summary: Archive of the gentoo-user-br mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.