Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-br
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-br@g.o
From: Daniel da Veiga <danieldaveiga@...>
Subject: Re: Problema com downgrade do gcc
Date: Fri, 18 Nov 2011 00:41:00 -0200
<div class="gmail_quote">2011/11/17 João Matos <span dir="ltr">&lt;<a href="mailto:jaoneto@...">jaoneto@...</a>&gt;</span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
Caros,<br>
<br>
Estava usando o 4.5.2, porém estou precisando desenvolver usando Cuda,<br>
q só e comatível com o 4.4. Dessa forma,<br>
<br>
- instalei o 4.4.6<br>
- mudei o perfil padrão para ele (gcc-config)<br>
-rodei um emerge -euDN world system<br>
-desistalei o 4.5.2<br>
-rodei emerge --depclean<br>
-revdep-rebuild<br>
<br>
Porém, ainda assim, não consigo usar muitos dos programas instalados. Erros:<br>
<br>
shaka@konoha ~ $ qtcreator<br>
Failed to load core: /usr/lib64/qtcreator/plugins/Nokia/libCore.so:<br>
Cannot load library /usr/lib64/qtcreator/plugins/Nokia/libCore.so:<br>
(/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so.6: version<br>
`GLIBCXX_3.4.14&#39; not found (required by<br>
/usr/lib64/qt4/libQtCLucene.so.4))<br>
shaka@konoha ~ $ chro<br>
chromium          chromium-browser  chroot<br>
shaka@konoha ~ $ chromium<br>
chromium-browser:<br>
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so.6: version<br>
`GLIBCXX_3.4.14&#39; not found (required by chromium-browser)<br>
shaka@konoha ~ $ firefox<br>
/usr/lib64/firefox/firefox-bin:<br>
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so.6: version<br>
`GLIBCXX_3.4.14&#39; not found (required by /usr/lib64/firefox/libxul.so)<br>
<br>
Alguém tem alguma ideia?<br></blockquote><div> </div><br>
Minha pergunta é, qual o motivo de usar o GCC que você precisa para 
desenvolver como global do sistema? Isso pode causar quebras gerais, 
visto que alguns programas podem reclamar de partes núcleo do sistema 
(glibc) que foram compiladas ou ainda dependem, ou estão linkadas com 
versões mais novas.<br>

<br>

Pq não deixar seu sistema rodando no 4.5 e criar um ambiente para 
desenvolver no 4.4 (um eselect antes deve resolver, quem sabe até um CHROOT) e voltar no final 
(se você quiser por exemplo atualizar o sistema). Quando eu tinha o QEMU
 que dependia de uma versão ancestral do GCC e quando usava 
cross-compiler eu fazia assim... YMMV.<br>
</div><br>O ponto é que existem bibliotecas necessárias das versões do GCC antigas, remover não é a melhor opção. Eu deixo as versões quando elas tem alguma dependência ou coisa parecida...<br><br>-- <br>Daniel da Veiga<br>

Replies:
Re: Problema com downgrade do gcc
-- João Matos
References:
Problema com downgrade do gcc
-- João Matos
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Problema com downgrade do gcc
Next by thread:
Re: Problema com downgrade do gcc
Previous by date:
Problema com downgrade do gcc
Next by date:
Re: Problema com downgrade do gcc


Updated Jul 05, 2012

Summary: Archive of the gentoo-user-br mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.