Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-br
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-br@g.o
From: João Matos <jaoneto@...>
Subject: Re: Problema com downgrade do gcc
Date: Sun, 20 Nov 2011 17:55:05 -0300
<br>&gt;  <br>&gt; Minha pergunta é, qual o motivo de usar o GCC que você precisa para<br>&gt; desenvolver como global do sistema? Isso pode causar quebras gerais, visto<br>&gt; que alguns programas podem reclamar de partes núcleo do sistema (glibc) que<br>

&gt; foram compiladas ou ainda dependem, ou estão linkadas com versões mais<br>&gt; novas.<br>&gt;<br>&gt; Pq não deixar seu sistema rodando no 4.5 e criar um ambiente para<br>&gt; desenvolver no 4.4 (um eselect antes deve resolver, quem sabe até um CHROOT)<br>

&gt; e voltar no final (se você quiser por exemplo atualizar o sistema). Quando<br>&gt; eu tinha o QEMU que dependia de uma versão ancestral do GCC e quando usava<br>&gt; cross-compiler eu fazia assim... YMMV.<br><br>Na verdade eu fiz um teste rápido, mudando o gcc ppra versão 4.4 usando o gcc-config, e ao abrir o qtcreator eu obtive aquele erro. Recompilei e não resolveu, então eu pensei em recompilar o sistema todo. :P Mas não resolveu. <br>

<br>Depois de tudo recompilado e depois de removido o gcc 4.5, recompilei o firefox, e ele passou a funcionar normalmente, porém o qt-creator e chromiun nada...<br><br><br>&quot;fix_libtool_files.sh 4.4 &amp;&amp; fix_libtool_files.sh 4.5&quot; não resolveu.<br>

<br>será q se eu apagar os arquivos listados abaixo e rodar um revdep-rebuild e resolvo, ou vou ter mais problemas do q ja tenho?<br><b><br>locate libstdc++ | grep -v win | grep -v share | grep -v portage</b><br>/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.a<br>

/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so<br>/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so.6<br>/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/libstdc++.so.6.0.13<br>/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/32/libstdc++.a<br>

/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/32/libstdc++.so<br>/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/32/libstdc++.so.6<br>/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.6/32/libstdc++.so.6.0.13<br><br><br><br><br>-- <br>João de Matos<br>

Linux User #461527<br>Graduando em Engenharia de Computação 2005.1<br>UEFS - Universidade Estadual de Feira de Santana<br><br>
References:
Problema com downgrade do gcc
-- João Matos
Re: Problema com downgrade do gcc
-- Daniel da Veiga
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Problema com downgrade do gcc
Next by thread:
Re: Problema com downgrade do gcc
Previous by date:
Re: Problema com downgrade do gcc
Next by date:
Problemas no Gentoo


Updated Jul 05, 2012

Summary: Archive of the gentoo-user-br mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.