Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-br
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-br@g.o
From: Alexandre Riveira <alexandre@...>
Subject: Re: novo na lista e duvida sobre gcc 4.6
Date: Thu, 11 Aug 2011 09:00:07 -0300
Bom dia  Zhu !<br><br>Obrigado pela dica !<br>Minha preocupacao nem eh compilar muitas coisas e mais saber se o gcc poderia gerar um binario instavel com relacao ao kernel especialmente, pois acredito que, a cada nova versao, o gcc deve ter otimizacoes que nao sei se afetariam a estabilidade do kernel.<br>
<br><br>Obrigado,<br><br><br>Alexandre Riveira<br><br><br><div class="gmail_quote">Em 11 de agosto de 2011 08:32, Zhu Sha Zang <span dir="ltr">&lt;<a href="mailto:zhushazang@...">zhushazang@...</a>&gt;</span> escreveu:<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">Minha máquina principal, uso 4.4 por causa do nvidia-sdk. Em algumas máquinas uso o 4.5 sem problemas, mas não testo tantos pacotes nela assim para saber se tudo que VOCÊ precisar vai compilar. E com certeza utilizar o 4.6 vai te dar dor de cabeça. Eu sugiro manter o gcc 4.4.<br>

<br>
Bem vindo e boa sorte.<br>
<br>
Em 10-08-2011 11:07, Pablo Hess escreveu:<div><div></div><div class="h5"><br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
Seja bem vindo, Alexandre.<br>
<br>
O banco de dados de pacotes online do Gentoo indica que a versão<br>
estável mais recente do GCC nas arquiteturas x86 e amd64 é a 4.4.5:<br>
&lt;<a href="http://packages.gentoo.org/package/sys-devel/gcc" target="_blank">http://packages.gentoo.org/<u></u>package/sys-devel/gcc</a>&gt;.<br>
<br>
O gcc-4.6.0 e o gcc-4.6.1 estão mascarados, ou seja, ainda estão em<br>
fase inicial de teste ou encontram-se instáveis.<br>
<br>
As versões 4.5.x do GCC estão marcadas como instáveis, o que significa<br>
que elas podem ter problemas de compilação ou talvez ainda sejam<br>
incapazes de compilar softwares importantes do seu sistema.<br>
<br>
<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
Minha duvida e confirmar se o gcc 4.4 e o padrao mesmo ! Pois na distrowatch<br>
consta na coluna stable o gcc 4.6.1.<br>
</blockquote>
É verdade. Um grande engano de quem quer que tenha informado isso. :(<br>
<br>
<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
Outra questao seria se, ao compilar com a ultima versao do gcc se isto<br>
poderia gerar uma instabilidade no sistema,<br>
visto que, provavelmente, muitos softwares ainda nao foram testados nessa<br>
versao.<br>
</blockquote>
Softwares compilados com uma versão muito recente do GCC não devem ter<br>
problemas de execução, mas podem ter de compilação. Ou seja, se você<br>
conseguir compilar com o GCC novo, ele deve funcionar direito. :)<br>
<br>
<br>
</blockquote>
<br>
<br></div></div>
-- <br>
<br>
---<br><font color="#888888">
Zhu Sha Zang<br>
<br>
<br>
</font></blockquote></div><br>
References:
novo na lista e duvida sobre gcc 4.6
-- Alexandre Riveira
Re: novo na lista e duvida sobre gcc 4.6
-- Pablo Hess
Re: novo na lista e duvida sobre gcc 4.6
-- Zhu Sha Zang
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: novo na lista e duvida sobre gcc 4.6
Next by thread:
wget na instalacao com livecd
Previous by date:
Re: novo na lista e duvida sobre gcc 4.6
Next by date:
wget na instalacao com livecd


Updated Jul 05, 2012

Summary: Archive of the gentoo-user-br mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.