Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-br
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-br@g.o
From: Raphael Bastos <tecnologia@...>
Subject: Re: Problema ao atualizar GLIBC par a versão 2.13-r4
Date: Thu, 8 Dec 2011 12:22:26 -0200
<br><div class="gmail_quote">Em 7 de dezembro de 2011 23:54, Dalton Barreto <span dir="ltr">&lt;<a href="mailto:daltonmatos@...">daltonmatos@...</a>&gt;</span> escreveu:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

Em 7 de dezembro de 2011 19:59, Raphael Bastos<br>
&lt;<a href="mailto:tecnologia@...">tecnologia@...</a>&gt; escreveu:<br>
<div class="im">&gt; Dalton, eu só desmascarei a budega do busybox e compilou de boa. A versão<br>
&gt; estável precisa da glibc antiga, o ebuild sys-apps/busybox-1.19.3-r1 corrige<br>
&gt; isso.<br>
&gt;<br>
&gt; ;)<br>
<br>
</div>Beleza! Que bom que resolveu! Qualquer coisa, poste aí! =)<br>
<div class="HOEnZb"><div class="h5"><br>
<br>
--<br>
Dalton Barreto<br>
<a href="http://daltonmatos.com" target="_blank">http://daltonmatos.com</a><br>
<br>
</div></div></blockquote></div><br>Oi Dalton,<br><br>Na verdade tive só esse probleminha ao recompilar o sistema, mas como o ldap tá funcionando legal eu ignorei.<br>É a primeira vez que eu uso openldap num Gentoo, eu usava antes em um CentOS. Ao recompilar ele diz que existe uma base (obviamente) e por isso não dá pra recompilar.<br>

Nesse caso há alguma configuração a ser feita para adequar isso ou faço outro &quot;workaround&quot; pra recompilar e boa?<br>Eu fiz um teste.... se eu mover esse diretório, recompilar e depois voltar funcionou redondo, porém queria algo que não requer tal &quot;trampo manual&quot;.<br>

<br>Take a look no erro. Qualquer ajuda agradeço muito.<br><br>&gt;&gt;&gt; Emerging (1 of 1) net-nds/openldap-2.4.24<br> * openldap-2.4.24.tgz RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                                                                [ ok ]<br>

<br> * This profile is merely a convenience for people who require a more<br> * minimal profile, yet are unable to use hardened due to restrictions in<br> * the software being used on the server. If you seek a secure<br>
 * production server profile, please check the Hardened project<br>
 * (<a href="http://hardened.gentoo.org">http://hardened.gentoo.org</a>)<br><br> * <br> * Scanning datadir(s) from slapd.conf and<br> * the default installdir for Versiontags<br> * (/var/lib/openldap-data may appear twice)<br>

 * <br> * - Checking /var/lib/openldap-data...<br> *    Non-tagged dir /var/lib/openldap-data<br> *    EEK! Non-empty non-tagged datadir, counting 13 files<br><br> * <br> * Your OpenLDAP Installation has a non tagged datadir that<br>

 * possibly contains a database at /var/lib/openldap-data<br> * <br> * Please export data if any entered and empty or remove<br> * the directory, installation has been stopped so you<br> * can take required action<br> * <br>

 * For a HOWTO on exporting the data, see instructions in the ebuild<br> * <br> * ERROR: net-nds/openldap-2.4.24 failed (setup phase):<br> *   Please move the datadir /var/lib/openldap-data away<br> * <br> * Call stack:<br>

 *                ebuild.sh, line  56:  Called pkg_setup<br> *   openldap-2.4.24.ebuild, line 213:  Called openldap_find_versiontags<br> *   openldap-2.4.24.ebuild, line 123:  Called die<br> * The specific snippet of code:<br>

 *                                      die &quot;Please move the datadir ${CURRENT_TAGDIR} away&quot;<br> * <br> * If you need support, post the output of &#39;emerge --info =net-nds/openldap-2.4.24&#39;,<br> * the complete build log and the output of &#39;emerge -pqv =net-nds/openldap-2.4.24&#39;.<br>

 * The complete build log is located at &#39;/var/log/portage/net-nds:openldap-2.4.24:20111208-133102.log&#39;.<br> * The ebuild environment file is located at &#39;/var/tmp/portage/net-nds/openldap-2.4.24/temp/die.env&#39;.<br>

 * S: &#39;/var/tmp/portage/net-nds/openldap-2.4.24/work/openldap-2.4.24&#39;<br><br>&gt;&gt;&gt; Failed to emerge net-nds/openldap-2.4.24, Log file:<br><br>&gt;&gt;&gt;  &#39;/var/log/portage/net-nds:openldap-2.4.24:20111208-133102.log&#39;<br>

<br><br>Att,<br>Raphael Bastos<br>
References:
Problema ao atualizar GLIBC para versão 2.13-r4
-- Raphael Bastos
Re: Problema ao atualizar GLIBC para versão 2.13-r4
-- Eduardo Schoedler
Re: Problema ao atualizar GLIBC par a versão 2.13-r4
-- Raphael Bastos
RES: Problema ao atualizar GLIBC para versão 2.13-r4
-- Eduardo Schoedler
Re: Problema ao atualizar GLIBC par a versão 2.13-r4
-- Raphael Bastos
Re: Problema ao atualizar GLIBC par a versão 2.13-r4
-- Dalton Barreto
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Problema ao atualizar GLIBC par a versão 2.13-r4
Next by thread:
Problema na atualização do openldap [was: Problema ao atualizar GLIBC para versão 2.13-r4]
Previous by date:
Re: Problema ao atualizar GLIBC par a versão 2.13-r4
Next by date:
Re: Problema ao atualizar GLIBC par a versão 2.13-r4


Updated Jul 05, 2012

Summary: Archive of the gentoo-user-br mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.