Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-br
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-br@g.o
From: Rodolfo Penha <rodolfo.penha@...>
Subject: Re: nvidia no gentoo não cri a os nodes em /dev
Date: Thu, 15 Sep 2005 14:00:42 -0300
Bem, não sei se alguém tentou seguir as minhas dicas, mas vão ai 
novamente...

Dê uma olhada no /etc/modules.d/nvidia e veja se contém as linhas:

alias char-major-195 nvidia
alias /dev/nvidiactl char-major-195

Se não estiverem lá, adicione e dê um modules-update. Veja se funciona.

Caso ainda não funcione, crie os nodes da seguinte forma:

mknod /dev/nvidiactl c 195 255
mknod /dev/nvidia0 c 195 0
chown root:video /dev/nvidia{ctl,0}
chmod 0660 /dev/nvidia{ctl,0}

Adicione os usuários que vc queira que tenham aceleração gráfica no 
grupo video.

Creio que isto resolva.

OBS: Meu RC_DEVICE_TARBALL está como "no"

Outro detalhe: compilei o kernel com suporte a devfs:

rodolfo modules.d # zcat /proc/config.gz |grep DEVFS
CONFIG_DEVFS_FS=y
# CONFIG_DEVFS_MOUNT is not set
# CONFIG_DEVFS_DEBUG is not set

Porém desabilito no grub.conf e habilito o udev:

title Gentoo Linux (Gentoo 2.6.12-gentoo-r6 - Framebuffer)
        root (hd0,0)
        kernel (hd0,0)/kernel-genkernel-x86-2.6.12-gentoo-r6 udev 
root=/dev/hda5 video=vesafb:ypan,1024x768-32@85 gentoo=nodevfs


Se alguém, obtiver sucesso com estas dicas, por favor, envie um 
"feedback" para a lista.

[ ]s

Rodolfo Penha

-- 
gentoo-user-br@g.o mailing list


Replies:
Re: nvidia no gentoo não cria os nodes em /dev
-- Renata Romanazzi
References:
nvidia no gentoo não cria os nodes em /d ev
-- Leandro de Araujo Teixeira
Re: nvidia no gentoo não cri a os nodes em /dev
-- Rodolfo Penha
Re: nvidia no gentoo não cri a os nodes em /dev
-- Wagner Hebert
Re: nvidia no gentoo não cria os nodes em /dev
-- Marcus Fazzi (Anunakin)
Re: nvidia no gentoo não cria os nodes em /dev
-- Renata Romanazzi
Navigation:
Lists: gentoo-user-br: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: nvidia no gentoo não cria os nodes em /dev
Next by thread:
Re: nvidia no gentoo não cria os nodes em /dev
Previous by date:
Re: Impedir a instalação de um pacote
Next by date:
Re: Impedir a instalação de um pacote


Updated Jun 17, 2009

Summary: Archive of the gentoo-user-br mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.