Gentoo Archives: gentoo-user-cs

From: Pavel Dobes <gentoo@×××.cz>
To: gentoo-user-cs@l.g.o
Subject: proc se mi KDE a QT nezamlovua WAS: Re: [gentoo-user-cs] Fonty v kmailu
Date: Wed, 04 Apr 2007 22:45:44
Message-Id: 20070405004519.5c598868@neo.local
In Reply to: Re: [gentoo-user-cs] Fonty v kmailu by "Jan Kundrát"
On Wed, 04 Apr 2007 22:43:36 +0200
Jan Kundrát <jkt@g.o> wrote:

> Pavel Dobes wrote: > > Ja bych se na KDE vykaslal. Kdyz ho musim upgrafovat kvuli nejakemu > > programu, ktery KDE potrebuje, tak jsem opravdu 'nadsen'. To same je > > i s qt, ale bohuzel cim vice programu tuto drobnost vyzaduje :-(. > > Tohle me fakt vzdycky pobavi :). Straaaasne zavislosti, jasne. Kdyz se > ti nejake knihovny z politickych duvodu nelibi, nepouzivej je, ale je > zbytecny to roztrubovat, IMHO.
1) KDE nepouzivam 2) nektere programy nemaji rozumnou nahradu a jsou z KDE (napr. editor ikon). Nevim, proc, kdyz chci tento program, musim instalovat kde-graphic. Mozna, ze se ta monoliticnost uz zmenila, ale... Kdyz v tom chci neco zmenit v tom jednom programu, tak musim nastavovat pres kcentrum (nebo jak se to jmenuje), ktere nastavuje vsechno mozny i nemozny. Proc neexistuje nejaka alternativni konfigurace? Neco, co by volitelne z kontrolniho centra vytahlo relavantni volby nasatveni a prilepilo se to treba do menu te ktere aplikace? OK muzu si pustit vim a konfigurovat XML, ale to neni prave ono. Z dokumentace se ani nedozvim, ktere volby chovani toho ktereho programu ovlivnuji a je to vzdy alchymie. neco naklikat a podivat se , jestli se to zmenilo tak, jak sem zamyslel. 3) nektere programy se rozhodnou, ze je zbytecne udrzovat vice grafickych toolkitu a vyberou qt, ktere se silene dlouho preklada... Uznavam, ze to neni chyba KDE nebo Trolltechu ale volba autonomnich vyvojaru, kteri zvolili tu kterou knihovnu zcela nezavisle. Ale pokud jsem zvyklej na to, ze kompiluji poroti XForms a najednou kvuli nove verzi musim mit qt, tak to zamrzi - asi stejne, jako, kdyz jsem upgradoval SuSE a zjistil jsem, ze do te doby bezproblemovy gdm jiz tak bezproblemovy neni (tipnete si, jaky tam byl default manager). Politika me nevadi, ale vadi mi, ze pro 1 aplikaci musim instalovat kde-base, kde-i18n atd. a to, ze qt se preklada ze vsech knihoven nejdele je fakt, ktery me vede k tomu, abych aplikace ktere qt pouzivaji nepouzival. Tim padem ale kazdy upgrade kvuli 1 nebo 2 programum je jeste viditelnejsi.
> > > Puvodne jsi psal neco o tom, ze > > marne hledas nahradu, tak ty vsechny experimenty budou rychlejsi, nez > > troji rebuild KDE. > > Jako argument proti kmailu beru "ma to pet let stare a neresene > bugreporty zpusobujici velke defekty" (coz je pravda), ne "je to z KDE" :). >
To, ze se musi prekompilovat neco z KDE je fakt. Je to konstatovani a ne hon na carodejnici KDE. Mozna, kdybych pouzival GNOME, tak bych byl proti KDE vyhranenejsi i politicky, ale to take nepouzivam. Nepouzivam KDE a neznam ho. Znam pouze dobu za jakou se KDE na mem pocitaci prelozi (ty nutne soucasti, ktere valstne ani nechci, chci pozue 1-2 konkretni apliakce) a s timto jedinym faktem operuji. Klidne bych bral bin baliky KDE. OpenOffice se kompiluje mnohem dele, ale to tolik nepocituji, prave proto, ze bin balik existuje.
> Hezky vecer,
Napodobne
> -jkt >
PaD -- gentoo-user-cs@g.o mailing list

Replies