Gentoo Archives: gentoo-user-es

From: Don d2clon <d2clon@×××××.com>
To: gentoo-user-es@l.g.o
Subject: Re: [gentoo-user-es] gentoo en un poweredge sc420
Date: Fri, 30 Sep 2005 15:08:08
Message-Id: ab6353c70509300807q73ee6389s3b1d776b1206e313@mail.gmail.com
(envío desde esta otra cuenta por que la cuenta
@desarrolladores.org <http://desarrolladores.org> me está fallando)



hola pcmaster:

me dejas super sorprendido con tu dominio sobre los módulos .. y bueno en
general .. :)

pcmaster wrote:

Hola,

En los mensajes que te muestra el sistema fíjate en un par de puntos:

El disco hda tiene un tamaño de sector de 2048 bytes. Eso es un CD. Los
discos duros usan sectores de 512 bytes. Es posible que el Cd arranque con
emulación de disco duro (si arrancase con emulación de disquet, sería de
1,44 MB y sería reconocido como disquetera, pero en eun disquet de 1,44 Mb
creo que no cabe un kernel 2.6).

sobre lo que dices de hda es el cdrom.. sí confirmado:
# ls -l /dev/hda
brw-rw---- 1 root cdrom 3, 0 Sep 28 19:41 /dev/hda
# ls -l /dev/ide/host0/bus0/target0/lun0/cd
lrwxrwxrwx 1 root root 18 Sep 28 19:41 /dev/ide/host0/bus0/target0/lun0/cd
-> ../../../../../hda

bueno no sé si esto confirma.. pero es bastante sujerente.. también que el
grupo de /dev/hda sea cdrom..


Si te fijas en los módulos que tienes cargados, uno de ellos es libata, es
decir, que ha detectado una conteroladora SATA. Si el disco es SATA, será
reconocido como disco SCSI, y el dispositivo será /dev/sda (o /dev/sdb,
/dev/sdc, etc).

estoy un poco perdido con la diferencia/relación entre SATA y SCSI.. pero en
las especificaciones leo que el disco duro es SCSI.. no sé si esto descarta
SATA o no:
DD: 73GB SCSI Ultra320 (10,000rpm) 68 pin


¿Tienes conectado algún disco Firewire? Fíjate que tienes cargado el módulo
sbp2 (soporte para discos duros USB 2.0 y Firewire) que utiliza el módulo
IEEE1394. Si no tiene sningún disco Firewire, intenta descargarlos.





Fíjate tambien que tienes cargados los módulos SATA:

ata_piix 5574 1
libata 25316 1 ata_piix

libata es el soporte SATA, y ata_piix el "driver" para el chipset de Intel.

Intenta descargarlos y volverlos a cargar, a ver qué pasa.

# rmmod ata_piix libata
ERROR: Module ata_piix is in use
ERROR: Module libata is in use by ata_piix

no sé que módulo tiene pillado al ata_piix .. grrr

[10minutos despues]
valla.. intentando descargar todos los módulos que parecía que no se estaban
usando.. e quitado el módulo de red.. quizás es mejor ir a descansar y
seguir el lunes :)


En la BIOS del PC puedes seleccionar dos modos para el interfaz SATA: el
nativo SATA y un segundo modo de "compatibilidad" en el cual emula un puerto
PATA. Si uno no te funciona por algún motivo prueba el otro, aunque en modo
nativo debería dar mejor rendimiento.

esto es lo que me han comentado en otra respuesta.. lo miraré..


Por último, si has intantado hacer RAID desde la BIOS, comprueba si ese RAID
es por software o hardware. Si lo hace por hard el chip SATA. ningún
problema, pero si es por software, necesita drivers "windoseros" y no
funcionara en Linux. En ese caso es mejor desactivar el RAID.

el raid 'creo' que es por hardware.. no me preocupa mucho por que no la voy
a usar:
Conectividad RAID: C4 SCSI, controladora Add in SCSI, Min 1/Max 2 Discos
Duros.



Saludos


saludos y gracias
el lunes continuamos.

d2clon