Gentoo Archives: gentoo-user-es

From: Alfonso Escribano <alfons@×××××××××××.es>
To: gentoo-user-es@g.o
Subject: Re: [gentoo-user-es] openoffice y acentos
Date: Sun, 26 May 2002 15:01:49
Message-Id: 3CF15AF9.7070603@est.unileon.es
In Reply to: Re: [gentoo-user-es] openoffice y acentos by pof
Hola,
Yo tuve ese mismo problema y lo solucione de manera algo distinta, baje 
openoffice en español, lo puse en /usr/portage/distfiles y luego cambie 
el ebuil pero solo cambie el nombre del archivo y la url de donde lo 
baje y luego hice el digest y hice un emerge normal y se me instalo a la 
perfección con acentos, eñes y con el simbolo del ¤ incluido.

Para ejecutarlo, en cada user distinto al root al ejecutarlo por primera 
vez te pide k lo instales, haces una instalacion local y tira 
perfectamente y no hace falta haccer el script, de variable para el 
lenguage y demas se puede poner también es_ES@euro mejor que es_ES y con 
poner LC_ALL=es_ES@euro valdria.

Yo tambien me consegui compilar todo con soporte español con acentos 
eñes y euro en locale, hay un post en el forum k explica bien como 
hacerlo, aunk hay k recompilar la base (osea bootstrap.sh otra vez con 
lo k conlleva eso).

Un saludo
Alfonso Escribano


pof wrote:

>On Sun, 26 May 2002 04:24:02 +0200 >"pof" <pau@××××××.org> wrote: > > > >>He instalado openoffice-bin-1.0-r1 y no consigo que funcionen las eñes y >>los acentos. >> >> > >Ya he solventado el problema, os cuento como por si a alguien le pasa lo mismo: > >1) He modificado el ebuild para que baje la versión de openoffcie internacionalizada en castellano: > >root@w0/usr/portage/app-office/openoffice-bin# diff openoffice-bin-1.0.0-r1.ebuild openoffice-bin-1.0.0-es.ebuild >18c18 >< S="${WORKDIR}/install" >--- > > >>S="${WORKDIR}/OOo1.0_linuxintel_spanish/normal" >> >> >20,21c20 >< SRC_URI="http://ny1.mirror.openoffice.org/${PV}/OOo_${MY_PV}_LinuxIntel_install.tar.gz >< http://sf1.mirror.openoffice.org/${PV}/OOo_${MY_PV}_LinuxIntel_install.tar.gz >--- > > >>SRC_URI="http://ftp.rediris.es/ftp/mirror/openoffice.org/l10n/OO-1.0.0-office.qkaka.com/Linux/OOo1.0_linuxintel_spanish.tgz >> >> >36c35 >< unpack OOo_${MY_PV}_LinuxIntel_install.tar.gz >--- > > >> unpack OOo1.0_linuxintel_spanish.tgz >> >> >root@w0/usr/portage/app-office/openoffice-bin# > >2) Ejecutamos ebuild digest para que baje el nuevo binario y genere el md5 correcto >3) Emerge unmerge de la versión anterior >4) rm -rf /opt/OpenOffice-1.0.0 && rm -rf ~/.sversionrc >5) emerge del nuevo ebuild >6) Lanzar OpenOffice con el siguiente script: > >pau@w0~$ cat bin/openoffice >#!/bin/bash >unset LC_ALL >unset LANG >export LANG="es_ES" >/usr/X11R6/bin/setxkbmap es >/opt/OpenOffice-1.0.0/soffice >pau@w0~$ > >Y esto es todo :) > >Salu2, > pof > > >

Replies

Subject Author
Re: [gentoo-user-es] openoffice y acentos pof <pau@××××××.org>