Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-es
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-es@g.o
From: enrique sardon <ensarman@...>
Subject: Re: problemas en postgres
Date: Thu, 14 Jan 2010 03:24:26 -0500
<br><br><div class="gmail_quote">El 14 de enero de 2010 02:00, Guillermo M. Narvaja <span dir="ltr">&lt;<a href="mailto:guillermo.narvaja@...">guillermo.narvaja@...</a>&gt;</span> escribió:<br>

<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">También podés probar los siguientes comandos:<br>
sudo su - postgres<br>
postmaster -D /var/lib/postgresql/8.4/data<br>
<br>
Al correrlo de esa forma vas a ver el error que está tirando postgres.<br>
En los logs no aparece nada? También podría llegar a ser que no inicie<br>
por que el parámetro &quot;shared_buffers&quot; supera los valores del kernel para<br>
shm_max... Y creo que hace poco tuve un error similar y era por un error<br>
en archivo /etc/hosts, ya que estaba mal definido localhost o algo<br>
así...<br>
<br></blockquote><div><br>muchas gracias, bueno me salio esto:<br><br>$postmaster -D /var/lib/postgresql/8.4/data<br>LOG:  could not create IPv6 socket: Address family not supported by protocol<br>FATAL:  database files are incompatible with server<br>

DETAIL:  The database cluster was initialized without HAVE_INT64_TIMESTAMP but the server was compiled with HAVE_INT64_TIMESTAMP.<br>HINT:  It looks like you need to recompile or initdb.<br><br>no entiendo eso de recompilar el initdb... <br>

 <br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>
<br>
El mié, 13-01-2010 a las 19:03 -0600, [ krieg ] nO_ok escribió:<br>
<div><div></div><div class="h5">&gt; Saludos,<br>
&gt;<br>
&gt; 2010/1/13 enrique sardon &lt;<a href="mailto:ensarman@...">ensarman@...</a>&gt;<br>
&gt;         holas Txeyen, hice lo que me dijiste pero no aparece un<br>
&gt;         servidor en ejecucion, del mismo modo el usuario postgres no<br>
&gt;         tiene  nungun proceso funcionando. es raro porque hasta hace<br>
&gt;         unos dias me funcionaba bien :S<br>
&gt;<br>
&gt;         #su postgres -c &quot;pg_ctl status<br>
&gt;         -D /var/lib/postgresql/8.4/data&quot;<br>
&gt;         pg_ctl: no hay servidor en ejecución<br>
&gt;<br>
&gt;<br>
&gt; Y no realizaste ninguna actualización con emerge algo que haya<br>
&gt; cambiado el script en /etc/init.d/postgresql-8.4 y que esté buscando<br>
&gt; un diferente directorio de datos?<br>
&gt;<br>
&gt; Solo lo pregunto por si las dudas... tal vez ahora con:<br>
&gt;<br>
&gt; $su postgres -c &quot;pg_ctl start -D /var/lib/postgresql/8.4/data&quot;<br>
&gt;<br>
&gt; Buenas noches.<br>
&gt;<br>
&gt;<br>
&gt;         igual:(<br>
&gt;<br>
&gt;         El 13 de enero de 2010 19:40, Txeyen<br>
&gt;         &lt;<a href="mailto:txeyen@...">txeyen@...</a>&gt; escribió:<br>
&gt;<br>
&gt;<br>
&gt;                 El Miércoles, 13 de Enero de 2010, enrique sardon<br>
&gt;                 escribió:<br>
&gt;                 &gt; grsacias por responder ,epro hice algunas pruebas<br>
&gt;                 como ver si el usuario<br>
&gt;                 &gt; postgres tiene algun porceso ejecutado:<br>
&gt;<br>
&gt;<br>
&gt;                 esto te dice si tienes un postgres funcionando:<br>
&gt;                 pg_ctl status -D datadir<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;         --<br>
&gt;         salu2<br>
&gt;<br>
&gt;         ennrique sardon<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; --<br>
&gt; Atte.<br>
&gt; -----------<br>
&gt; K r i e g!<br>
</div></div>--<br>
Guillermo M. Narvaja<br>
Lambda Sistemas S.R.L.<br>
<a href="http://www.fierro-soft.com.ar" target="_blank">www.fierro-soft.com.ar</a><br>
Tel: (5411) 4857-6662<br>
Cel: (5411) 15-6783-4435<br>
Email: <a href="mailto:guillermo.narvaja@...">guillermo.narvaja@...</a><br>
MSN: <a href="mailto:guillermo_narvaja@...">guillermo_narvaja@...</a><br>
Skype: guillermonarvaja<br>
Lavalleja 519 1er Piso - Ciudad de Buenos Aires - Argentina<br>
<br>
<br>
</blockquote></div><br><br clear="all"><br>-- <br>salu2<br><br>ennrique sardon<br>
Replies:
Re: problemas en postgres
-- Guillermo M. Narvaja
References:
problemas en postgres
-- enrique sardon
Re: problemas en postgres
-- [ krieg ] nO_ok
Re: problemas en postgres
-- enrique sardon
Re: problemas en postgres
-- Txeyen
Re: problemas en postgres
-- enrique sardon
Re: problemas en postgres
-- [ krieg ] nO_ok
Re: problemas en postgres
-- Guillermo M. Narvaja
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: problemas en postgres
Next by thread:
Re: problemas en postgres
Previous by date:
Re: problemas en postgres
Next by date:
Re: problemas en postgres


Updated May 29, 2012

Summary: Archive of the gentoo-user-es mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.