Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-es
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-es@g.o
From: "Guillermo M. Narvaja" <guillermo.narvaja@...>
Subject: Re: problemas en postgres
Date: Thu, 14 Jan 2010 10:04:12 -0300
El jue, 14-01-2010 a las 03:24 -0500, enrique sardon escribió:
> 
> 
> El 14 de enero de 2010 02:00, Guillermo M. Narvaja
> <guillermo.narvaja@...> escribió:
>         También podés probar los siguientes comandos:
>         sudo su - postgres
>         postmaster -D /var/lib/postgresql/8.4/data
>         
>         Al correrlo de esa forma vas a ver el error que está tirando
>         postgres.
>         En los logs no aparece nada? También podría llegar a ser que
>         no inicie
>         por que el parámetro "shared_buffers" supera los valores del
>         kernel para
>         shm_max... Y creo que hace poco tuve un error similar y era
>         por un error
>         en archivo /etc/hosts, ya que estaba mal definido localhost o
>         algo
>         así...
>         
> 
> muchas gracias, bueno me salio esto:
> 
> $postmaster -D /var/lib/postgresql/8.4/data
> LOG:  could not create IPv6 socket: Address family not supported by
> protocol
> FATAL:  database files are incompatible with server
> DETAIL:  The database cluster was initialized without
> HAVE_INT64_TIMESTAMP but the server was compiled with
> HAVE_INT64_TIMESTAMP.
> HINT:  It looks like you need to recompile or initdb.
> 
> no entiendo eso de recompilar el initdb... 
>  
> 


Aparentemente tu directorio de bases de postgres fue creado con una
versión anterior de Postgresql o con algúna opción de compilación
distinta. Generalmente al cambiar de versión de 8.2.x a 8.3.x (o 8.3.x a
8.4.x, etc) tenés que volver a inicializar el directorio de datos de
postgresql. Previamente tendrías que backupear las base en la versión
anterior y luego restaurarlas en la nueva.

Viendo los ebuilds de postgresql, creo que puede ser que te falte el
USE=pg_legacytimestamp , es lo más parecido al error que te tira. 

El "initdb" se hace generalmente en gentoo mediante emerge --config
postgresql .



-- 
Guillermo M. Narvaja
Lambda Sistemas S.R.L.
www.fierro-soft.com.ar
Tel: (5411) 4857-6662
Cel: (5411) 15-6783-4435
Email: guillermo.narvaja@...
MSN: guillermo_narvaja@...
Skype: guillermonarvaja
Lavalleja 519 1er Piso - Ciudad de Buenos Aires - Argentina



Replies:
Re: problemas en postgres
-- enrique sardon
References:
problemas en postgres
-- enrique sardon
Re: problemas en postgres
-- [ krieg ] nO_ok
Re: problemas en postgres
-- enrique sardon
Re: problemas en postgres
-- Txeyen
Re: problemas en postgres
-- enrique sardon
Re: problemas en postgres
-- [ krieg ] nO_ok
Re: problemas en postgres
-- Guillermo M. Narvaja
Re: problemas en postgres
-- enrique sardon
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: problemas en postgres
Next by thread:
Re: problemas en postgres
Previous by date:
Re: problemas en postgres
Next by date:
Re: problemas en postgres


Updated May 29, 2012

Summary: Archive of the gentoo-user-es mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.