Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-es
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: <gentoo-user-es@g.o>
From: "Facundo Ortiz de Zarate" <facundooz@...>
Subject: RE: apache + ssl
Date: Fri, 30 Sep 2005 16:57:54 -0300
Gracias d2clon y chelmiki por la ayuda, ya lo tengo andando...
efectivamente, me faltaba poner en el conf.d el
  APACHE2_OPTS="-D DEFAULT_VHOST -D SSL -D SSL_DEFAULT_VHOST -D PHP4"...
y con la salvedad de que tuve que cambiar la ubicación de los certificados
porque el apache actual cambió el apache.conf por httpd.conf, y anuló la
carpeta  conf. En el <vhosts> tengo así (estará bien?):
<VirtualHost *:443>
    ServerAdmin webmaster@...
    DocumentRoot /var/www/localhost/htdocs
    ServerName www.dominio.com:443
    SSLProtocol TLSv1
    SSLCipherSuite HIGH:MEDIUM
    SSLCertificateFile /etc/apache2/ssl/server.crt
    SSLCertificateKeyFile /etc/apache2/ssl/server.key
    SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
    RewriteEngine On
    RewriteOptions inherit
</VirtualHost>
    No sé muy bien si hacen falta o no, porque lo copié de un foro de
gentoo.org, pero dejé tal cual el SetEnvif y los Rewrite.
 
  Sólo me queda esta duda: *cada vez* que entro en el sitio asegurado, me
avisa (tanto el ie como el firefox y el Netscape) que hay un certificado,
etc. etc. que le dé ok para entrar. Se puede hacer que me lo pregunte la
primera vez, solamente? O debo conseguir un certificado de VeriSign para
eso?
 
De nuevo gracias
 

Facundo 

 


________________________________

	De: Don d2clon [mailto:d2clon@...] 
	Enviado el: Viernes 30 de Septiembre de 2005 15:06
	Para: gentoo-user-es@g.o
	Asunto: Re: [gentoo-user-es] apache + ssl
	
	
	sin olvidar que gentoo tiene una documentacion envidiable: 
	http://gentoo-wiki.com/Apache_Modules_mod_ssl
	
	pero este wiki tiene alguna cosa rara.. nose. :)
	
	
	On 9/30/05, Facundo Ortiz de Zarate <facundooz@... >
wrote: 

		Hola a todos,
		        estoy tratando de hacer andar mi apache de siempre,
que tiene 
		configurado el vhosts con varios hostings(pero con una sola
ip).Este
		webserver está detrás de una Pc con un firewall, que
redirecciona los
		puertos según que sea para el apache, el qmail, mysql, etc.
		        Todo anda bien, hasta que instalé el group-office.
cuando lo mostré 
		en la oficina, me pidieron que lo pusiera con una conexión
segura(con
		ssl...)
		Lo que hice fue levantar el apache con el parámetro "-D
SSL", y en el
		archivo vhosts intenté ponerle
		<VirtualHost *:443> 
		.....
		</VirtualHost>
		Pero me da error. Y si pongo
		NameVirtualHost *:443
		no pasa nada. En el firewall redirecciono el puerto 443(tcp)
a la ip del
		servidor apache.
		Perdonen mi ignorancia, ya busqué how-tos o doc simples
sobre el tema, pero 
		no logro entender. Me podrían pasar alguno, para
orientarme??
		Otra cosa: Está bien si en el firewall redirecciono *sólo*
el TCP:443 al
		apache, o tengo que hacer algo más?
		
		Gracias
		
		
		Facundo
		
		--
		gentoo-user-es@g.o mailing list
		
		



-- 
gentoo-user-es@g.o mailing list


Replies:
Re: apache + ssl
-- d2clon
References:
Re: apache + ssl
-- Don d2clon
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: apache + ssl
Next by thread:
Re: apache + ssl
Previous by date:
Re: apache + ssl
Next by date:
Re: ccache no funciona...


Updated Jun 17, 2009

Summary: Archive of the gentoo-user-es mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.