Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-es
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-es@g.o
From: Leonardo Boshell <gentoo@...>
Subject: Re: Problema de Instalacion Gentoo 1.2
Date: Wed Jun 26 20:42:01 2002
Hola Jorge.

Curiosamente, la primera vez que realicé una instalación de Gentoo
Linux, fue sobre un equipo con el mismo chipset que describes, y tuve
(si no recuerdo mal) exactamente el mismo problema.

Al parecer el inconveniente se debe, como correctamente has inferido, a
un problema de configuración a la hora de preparar el kernel.

Intenta incluyendo soporte de framebuffer para el chipset sis (sisfb),
ya que esos archivos incluyen las funciones (símbolos) que el mensaje de
error indica.

Si configuras el kernel mediante ``make menuconfig'', puedes encontrar
esta opción bajo: Console Drivers -> Frame buffer support -> Support for
frame buffer devices -> SIS acceleration -> (alguna de las dos opciones,
dependiendo del chipset, creo que yo usé SIS 630/540/730).

Las variables en el archivo .config son CONFIG_FB_SIS y
(CONFIG_FB_SIS_300 o CONFIG_FB_SIS_315).

Básicamente, el error se debe a que cuando activas soporte para AGP (o
DRI, no me acuerdo bien) específico para el chipset SIS, es obligatorio
que habilites asimismo el soporte para frame buffer de SIS.


Espero que te resulte bien. Un cordial saludo,

Leonardo


> Hola amigos de la lista.
> La consulta es puntual. Estoy instalando Gentoo 1.2 del iso grande, el 
> stage3, mi maquina es Celeron 366. he leido todos los manuales de 
> instalacion de la pagina de Gentoo, pero no soluciono mi problema.
> 
> luego de hacer: make menuconfig, donde CREO ¿? haber configurado todo 
> Ok, procedo a hacer: make dep && make clean bzImage modules 
> modules_install. Paciencia mientras compila...
> 
> Aqui viene el problema. NO COMPILA MI KERNEL!!! mensaje de error:
> make [vmlinuz] Error 1
> y arriba sale un problema con los archivos : drm.o y network.o
> Undefined reference: sis_malloc sis_free dev_add_pack dev_remove_pack...
> No en ese orden, pero los errores delos archivos sis_ se relacionan con 
> drm.o y los de dev_ con network.o
> A proposito, no tengo tarjeta de red, y mi chipset es SiS 620. 
> 
> He modificado 4 veces el menuconfig del kernel y son exactamente los 
> mismos errores...
> 
> Espero sugerencias que me ayuden a encontrar el camino!
> Jorge.
> 
> _______________________________________________
> gentoo-user-es mailing list
> gentoo-user-es@g.o
> http://lists.gentoo.org/mailman/listinfo/gentoo-user-es
> 




References:
Problema de Instalacion Gentoo 1.2
-- jorge_unmsm
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Problema de Instalacion Gentoo 1.2
Next by thread:
Post-instalacion Gentoo 1.2
Previous by date:
Problema de Instalacion Gentoo 1.2
Next by date:
Post-instalacion Gentoo 1.2


Updated Jun 17, 2009

Summary: Archive of the gentoo-user-es mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.