Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-es
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-es@g.o
From: pof <pau@...>
Subject: comportamiento raro de el comando emerge
Date: Fri Jul 26 22:32:01 2002
Hay una cosa que no me ha quedado clara sobre el funcionamiento del comando emerge. Voy a explicarme con un ejemplo, que creo que es la mejor forma hacerme entender:

- tengo instalado sylpheed-claws-0.7.8
- hago un 'emerge --clean rsync'
- hay una nueva version: sylpheed-claws-0.8.0
- hago lo siguiente:

> root@w0~# emerge --pretend --update world
> 
> These are the packages that I would merge, in order.
> 
> Calculating world dependencies ...done!
> [ebuild    U ] net-mail/sylpheed-claws-0.8.0 to /
> 
> root@w0~#


Como veis, tengo que actualizar sylpheed-claws, hasta aquí todo bien.
*** ahora viene el comportamiento que no entiendo ***

Se supone que haciendo un 'emerge --update sylpheed-claws' tendría que actualizarlo, pero no es así:

> root@w0~# emerge --pretend --update sylpheed-claws
> 
> These are the packages that I would merge, in order.
> 
> Calculating dependencies ...done!
> 
> root@w0~#


El emerge se queda tan ancho y no me actualiza sylpheed-claws :(
Pruebo añadiendo la categoría delante:

> root@w0~# emerge --pretend --update net-mail/sylpheed-claws
> 
> These are the packages that I would merge, in order.
> 
> Calculating dependencies ...done!
> 
> root@w0~# 


Tampoco funciona, en cambio poniendo la ruta completa si que lo hace:

> root@w0~# emerge --pretend --update /usr/portage/net-mail/sylpheed-claws/sylpheed-claws-0.8.0.ebuild 
> 
> These are the packages that I would merge, in order.
> 
> Calculating dependencies ...done!
> [ebuild    U ] net-mail/sylpheed-claws-0.8.0 to /
> 
> root@w0~#


y pruebo sin poner el '--update' y entonces quiere reinstalar la versión antigua:

> root@w0~# emerge --pretend sylpheed-claws
> 
> These are the packages that I would merge, in order.
> 
> Calculating dependencies ...done!
> [binary   R  ] net-mail/sylpheed-claws-0.7.8-r1 to /
> 
> root@w0~#


Así que al final tengo que acabar especificando el path entero hacia el ebuild para que lo compile.
Ahora vienen mis dudas: ¿Esto es normal? ¿Os pasa a todos o sólo me pasa a mi? ¿No debería funcionar especificando el nombre o como máximo la categoría y el nombre? ¿por que a veces pasa y a veces no pasa...?

Estoy utilizando portage-2.0.13.

Esto es todo, perdonarme si me he extendido demasiado.

Salu2,
	Pau.

-- 
 .----------------------------------------------.
|  Pau Oliva Fora         http://pof.eslack.org  |
|  KeyID: 665D05B533539E02 available at keyserv  |
 `----------------------------------------------'
Attachment:
pgp8STFKzInlb.pgp (PGP signature)
Navigation:
Lists: gentoo-user-es: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[gentoo-announce] net-misc/fakeidentd has been removed
Next by thread:
[linuxdummybudy@yahoo .es: [Bulma] De los Debianitas, Gentooados y BSD eros (leer sólo en caso de aburrimiento)]
Previous by date:
[gentoo-announce] net-misc/fakeidentd has been removed
Next by date:
[linuxdummybudy@yahoo .es: [Bulma] De los Debianitas, Gentooados y BSD eros (leer sólo en caso de aburrimiento)]


Updated Jun 17, 2009

Summary: Archive of the gentoo-user-es mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.