Gentoo Archives: gentoo-user-fr

From: Alex Vasic <alexis.vasic@××××.fr>
To: gentoo-user-fr@l.g.o
Subject: Re: [gentoo-user-fr] Problème médias amovibles et udev/udisks, polkit etc...
Date: Sun, 24 Apr 2011 09:03:38
Message-Id: 918561148.138921303633285023.JavaMail.root@zimbra11-e2.priv.proxad.net
Bonjour, 

Je n'ai pas pu m'occuper jusque là du problème mais je tiens à vous dire grand merci Jean-Philippe, le problème est (enfin) résolu. C'est dommage que thunar-volman soit obligatoire (en pensant à activer l'automount dans les options de thunar-volman), et reste curieux que sans thunar refuse de monter les médias. Je vais peut-être le signaler chez Xfce (si ce n'est déjà fait). Je récapitule si d'autres ont le même problème que moi : 

- Si présence d'un fichier comme /etc/udev/rules.d/11-media-by-label-auto-mount.rules, le supprimer 
- Installer thunar-volman et activer les options d'automount à l'insertion. 

Bref, voilà une bonne chose de faite pour Pâques, dont je vous souhaite de joyeuses fêtes =) 

Alex. 
----- Mail Original ----- 
De: "Jean-Philippe ROPA" <sboub88@×××××.com> 
À: gentoo-user-fr@l.g.o 
Envoyé: Vendredi 1 Avril 2011 12h35:03 GMT +02:00 Harare / Pretoria 
Objet: Re: [gentoo-user-fr] Problème médias amovibles et udev/udisks, polkit etc... 

Effectivement, il faut installer thunar-volman. 

Pour ce qui concerne ceux qui modifient 
/usr/share/polkit-1/actions/ org.freedesktop.udisks.policy 
j'avais fait de même avant de me rendre compte 
que ma session n'était pas enregistrée par consolekit. 
Donc inutile depuis. 

Jean-Philippe 


Le 1 avril 2011 09:05, Alex Vasic < alexis.vasic@××××.fr > a écrit : 




Merci Jean-Philippe pour l'aide, 

Cela n'a que peu changé. Maintenant lorsque je tente d'accéder par l'icône thunar j'ai le laconique message "Not Authorized" (alors qu'auparavant je n'avais aucun message), et la clé n'est plus auto-montée dans /media/usbhd-sdc1. Par contre, effectivement, le démontage par udisks ne demande plus de mot de passe. 
Ça n'a peut-être rien à voir mais comme je ne sais pas d'où vient le problème : j'ai le paquet thunar-vfs qui est installé (dépendance nécessaire pour xfburn), vu que ça a un rapport avec les systèmes de fichiers et que le paquet est déprécié, et je n'ai pas le paquet thunar-volman d'installer (qui gère le montage et l'accès des médias automatiquement « à la Windows »). Je vais tenter de voir avec ça. 

Ah, et avant que j'oublie, j'avais lu que certains modifiaient le fichier /usr/share/polkit-1/actions/org.freedesktop.udisks.policy, voici les parties concernées pour le montage : 

<action id="org.freedesktop.udisks.filesystem-mount"> 
<description>Mount a device</description> 
<description xml:lang="da">Montér en enhed</description> 
<message>Authentication is required to mount the device</message> 
<message xml:lang="da">Autorisering er påkrævet for at montere et fil system</message> 
<defaults> 
<allow_any>no</allow_any> 
<allow_inactive>no</allow_inactive> 
<allow_active>yes</allow_active> 
</defaults> 
</action> 

<action id="org.freedesktop.udisks.filesystem-mount-system-internal"> 
<description>Mount a system-internal device</description> 
<description xml:lang="da">Montér en intern enhed</description> 
<message>Authentication is required to mount the device</message> 
<message xml:lang="da">Autorisering er påkrævet for at montere et fil system</message> 
<defaults> 
<allow_any>no</allow_any> 
<allow_inactive>no</allow_inactive> 
<allow_active>auth_admin_keep</allow_active> 
</defaults> 
</action> 

Cordialement, 


Alex.