Gentoo Archives: gentoo-user-fr

From: "M. ROPA" <sboub88@×××××.com>
To: gentoo-user-fr@l.g.o
Subject: Re: [gentoo-user-fr] Problème médias amovibles et udev/udisks, polkit etc...
Date: Thu, 31 Mar 2011 07:04:00
Message-Id: 4D9424CD.40407@gmail.com
In Reply to: Re: [gentoo-user-fr] Problème médias amovibles et udev/udisks, polkit etc... by Alex Vasic
Je me suis mal exprimé, j'aimerais savoir comment vous lancez xfce
et si celui si a bien sa session enregistrée sous consolekit.
Que donne la commande : ck-list-sessions
Il faut obtenir : active = TRUE

Sinon, pour lancer xfce il faut utiliser la commande :
exec ck-launch-session startxfce4
et non
exec startxfce4
dans .xinitrc si c'est lui qui lance xfce4.

Jean-Philippe



Le 30/03/2011 20:47, Alex Vasic a écrit :
> Merci Stéphane, > > Oui je me suis mal exprimé, ce n'est pas aléatoire (j'avais mis « > quelconque »), cela ne change rien au fait que j'ai lu que normalement > le montage auto se faisait dans /media/usbhd-sd** si on n'avait rien > renseigné dans fstab (ce qui est mon cas). > > Voici le cat /proc/mounts (avec une clé auto-montée) : > > rootfs / rootfs rw 0 0 > /dev/root / ext4 rw,noatime,barrier=1,data=ordered 0 0 > proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0 > sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0 > udev /dev tmpfs rw,nosuid,relatime,size=10240k,mode=755 0 0 > devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0 > /dev/sda4 /mnt/Stockage ext4 > rw,nosuid,nodev,noexec,noatime,barrier=1,data=ordered 0 0 > shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0 > usbfs /proc/bus/usb usbfs > rw,nosuid,noexec,relatime,devgid=85,devmode=664 0 0 > binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc > rw,nosuid,nodev,noexec,relatime 0 0 > /dev/sdc1 /media/usbhd-sdc1 vfat > rw,relatime,gid=100,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro > 0 0 > > Sinon j'ai du neuf : j'ai en fait bien accès à la clé usb avec thunar, > si je vais dans le répertoire /media/usbhd-sdc1, je peux tout faire : > lire, supprimer des fichiers... pour la dernière action, la > suppression est directe et ne passe plus par le dossier Trash. Sinon, > je ne peux avoir accès par l'icône sur le bureau ou l'icône dans > thunar (le « Système de fichiers 1G »). J'ai l'impression que thunar > s'embrouille entre la commande mount et la commande udisks. Les > fichiers sur la clé sont en propriétaire root, et le groupe « users » > a les accès en rw. Ça sembler sonner normal. J'ai attendu une mise à > jour de thunar (1.2.1) mais le problème persiste, et je consulte les > forums je semble être le seul à avoir le problème. Sinon > Jean-Philippe, ce n'est pas un problème de session, j'ai bien modifié > mon xinitrc et je n'ai aucun souci ni pour éteindre ni pour redémarrer > le pc. > > Si ça peut guider, voici mon > /etc/polkit-1/localauthority.conf.d/50-localauthority.conf (le seul > fichier que j'ai dans le dossier) : > > [Configuration] > AdminIdentities=unix-user:0 > > et mon fichier /etc/udev/rules.d/11-media-by-label-auto-mount.rules : > > KERNEL!="sd[a-z][0-9]", GOTO="media_by_label_auto_mount_end" > > # Import FS infos > IMPORT{program}="/sbin/blkid -o udev -p %N" > > # Get a label if present, otherwise specify one > ENV{ID_FS_LABEL}!="", ENV{dir_name}="%E{ID_FS_LABEL}" > ENV{ID_FS_LABEL}=="", ENV{dir_name}="usbhd-%k" > > # Global mount options > ACTION=="add", ENV{mount_options}="relatime" > # Filesystem-specific mount options > ACTION=="add", ENV{ID_FS_TYPE}=="vfat|ntfs", > ENV{mount_options}="$env{mount_options},utf8,gid=100,umask=002" > > # Mount the device > ACTION=="add", RUN+="/bin/mkdir -p /media/%E{dir_name}", > RUN+="/bin/mount -o $env{mount_options} /dev/%k /media/%E{dir_name}" > > # Clean up after removal > ACTION=="remove", ENV{dir_name}!="", RUN+="/bin/umount -l > /media/%E{dir_name}", RUN+="/bin/rmdir /media/%E{dir_name}" > > # Exit > LABEL="media_by_label_auto_mount_end" > > Peut-être un bug au niveau de thunar ? Comment en être sûr ? > > >----- Mail Original ----- > >De: "Stéphane Guedon" <stephane@××××××××××.eu> > >À: gentoo-user-fr@l.g.o > >Envoyé: Mercredi 30 Mars 2011 14h26:09 GMT +02:00 Harare / Pretoria > >Objet: Re: [gentoo-user-fr] Problème médias amovibles et > udev/udisks, polkit etc... > > >Déjà, le point de montage n'est pas aléatoire ! Ici, il correspond à > un numero > >de série ou similaire > > >Pour fixer le point de montage, tu peux utiliser les labels de > systèmes de > >fichiers, je te renvoie vers la doc d'ubuntu qui est bien faite : > > >http://doc.ubuntu-fr.org/tutoriel/comment_renommer_un_disque > > >Ensuite, pour le problème de base réel... Quand tu branche ta clé, > mais que tu > >ne peut y acceder, la monter ou la demonter... que donne le resultat > de la > >commande mount ? ou la lecture de /proc/mounts ? >

Replies

Subject Author
Re: [gentoo-user-fr] Problème médias amovibles et udev/udisks, polkit etc... Alex Vasic <alexis.vasic@××××.fr>