Gentoo Archives: gentoo-user-fr

From: Revolver Onslaught <revolver.onslaught@×××××.com>
To: gentoo-user-fr@l.g.o
Subject: Re: [gentoo-user-fr] [grub] stage1 non trouve
Date: Mon, 28 Jul 2008 14:33:09
Message-Id: 6e4abe2d0807280733n398f4060q9b76e3a6569692d6@mail.gmail.com
In Reply to: Re: [gentoo-user-fr] [grub] stage1 non trouve by Nicolas Sebrecht
Nicolas,

Mes réponses ci-dessous.

Le 28 juillet 2008 15:35, Nicolas Sebrecht <nicolas.s-dev@×××××××.net> a écrit :
> > Revolver Onslaught a écrit: > > Merci pour ces multiples idees. Les sorties sont dans le fichier > joint. En esperant que l on trouve le pourquoi. > > Non. J'avais pensé à un problème « d'inode size ». Il est à 256 chez > toi. La version 0.97 de grub est patchée chez Gentoo pour supporter > cette taille.
Bon, on trouveras autre chose.
> > Sinon, quelle est la solution alternative ? > > Installer grub en dehors du chroot. Cela nécessite un liveCD avec grub. > Voir l'option « config-file » en particulier.
J'avais essayé en précisant le fichier de conf situé dans /mnt/gentoo/boot/grub/menu.lst
> > Merci de ne pas goret quoter.
J'ignore ce que signifie "goret quoter" mais je pense qu'il s'agit des multiples >
> > Tu n'as visiblement pas compris. C'est la dernière fois que je réponds > à un de tes messages si tu ne fais pas l'effort de citer correctement. > > Tu devrais lancer un check sur le système de fichiers au cas où.
Ca a été fait avec fsck.ext3
> > Toujours valable. > > Ajoute « set -xv » au début du script grub-install (qui devrait être > dans /sbin). Puis seulement alors : > # grub-install /dev/sda > > J'avais bien dit : « Ajoute (...) au début du script », mais ce n'est > pas ce que tu as fais. Ce que tu as présenté est inutile.
J'avais fais un set -xv avant de lancer les commandes. Ce n'était pas bon ? Je peux recommencer s'il faut. Merci pour ton aide.

Replies

Subject Author
Re: [gentoo-user-fr] [grub] stage1 non trouve Nicolas Sebrecht <nicolas.s-dev@×××××××.net>