Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-fr
Navigation:
Lists: gentoo-user-fr: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-fr@g.o
From: delange@...
Subject: Re: [XFree86]
Date: Mon, 25 Aug 2003 10:05:49 +0200
FRLinux wrote:
> Salut,
> 
> Ne t'excuses pas, on debute tous un jour :)
> 
> Plusieurs possibilites. 
> 
> 1. As tu emerge xfree-drm egalement ?

Oui, c'est une des premières choses que j'ai faites, ainsi que de mettre 
'rage128' dans USE.
> 2. Je suppose que tu tournes en kernel 2.4, quelles sont les lignes
> concernant ati ou r128 dans le demarrage du kernel ? fait : 
> dmesg |grep -i ati && dmesg |grep -i r128
J'ai également recompilé le noyau pour avoir agpgart, usb, et le support 
USB pour le pilote de mon modem Sagem (adiusbadsl). Le support AGP est 
bien présent (un grep -i agpgart renvoit la reconnaissance du matériel), 
mais le grep sur ATI ou r128 ne donne rien et j'ai un 'module failed' au 
chargement des 'modules dependencies' concernant 'agpgart'. Je pense 
qu'il y a quelque chose que je ne comprends pas dans la philosophie de 
de /etc/modules.autoload, puisqu'il semble y avoir un conflit.

> 3. As tu tente d'installer des pilotes gatos ? (http://gatos.sf.net) si
> la reponse est oui, c'est pour cela que tu ne peux plus demarrer ton X.

Non, non, moi pas avoir touché à GATOS. Moi être orthodoxe : d'abord 
faire fonctionner et comprendre Gentoo (venant de Debian, je pense que 
plus c'est simple, mieux ça marche).
> 4. fais egalement un : grep EE /var/log/XFree86.0.log et copie ca dans
> ton email de reponse.
 > 5. Enfin, recompile ton petit kernel une fois et vois si cela resouds le
 > probleme.
 >
 > Steph
 >

Au début, avant la recompile du noyau, j'avais des messages d'erreur 
concernant DRI. Mais j'ai lu dans la doc Gentoo, que pour le support des 
cartes ATI rage128, qu'il ne fallait pas compiler dans le noyau le 
support DRM. Donc, j'ai bien le support AGP, mais pas le support ATI 128 
DRM. J'ai compilé un noyau 2.4.20.
Il y a peut-être aussi une autre cause à mes soucis : je ne compile pas 
comme il faut le noyau. Je prends la méthode classique :
make menuconfig
make dep
make bzImage
make modules
make modules_install
etc. (avec les procédures qui concernent le lien vers le bon dossier, 
vmlinuz, lilo, etc.). Mais peut-être pour la compile d'un noyau pour 
Gentoo y a t-il des subtilités qui m'échappent.

> On Sat, 2003-08-23 at 22:08, delange@... wrote:
> 
>>Hello!
>>Je suis nouveau sur Gentoo (commencé en juin à installer une 1.4rc4, 
>>puis les vacances loin d'une machine ...). Je viens d'uprder vers la 1.4 
>>je suppose, puisque j'ai fait un 'emerge -u system', suivi d'un 'emerge 
>>-u world'. Tout semble ok, sauf que je n'arrive pas à lancer le serveur 
>>X. J'ai un 'unresolved symbols' concernant le driver r128_drv. Ma carte 
>>graphique est une ATI Rage Fury 128 AGP. Je ne vois pas ce qui cloche 
>>avec le Xfree86Config. j'ai mis le r128 dans modules.autoload, qui 
>>justement n'est pas chargé au démarrage. Une idée sur les pistes à 
>>suivre . Et mille excuses pour le niveau au ras des paquerettes ...
>>JP
>>
>>
>>--
>>gentoo-user-fr@g.o mailing list


-- 
"Few discoveries are more irritating than those
  which expose the pedigree of ideas."
  Lord Acton


--
gentoo-user-fr@g.o mailing list

References:
Re: [Id�
-- neerd neerd
Re: [IdXe]
-- dju`
Re: [IdXe]
-- Ni[o
Re: [XFree86]
-- delange
Re: [XFree86]
-- FRLinux
Navigation:
Lists: gentoo-user-fr: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: [XFree86]
Next by thread:
peripheriques non reconnus
Previous by date:
Re: info sur le prelink
Next by date:
Goodbye


Updated Jun 17, 2009

Summary: Archive of the gentoo-user-fr mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.