Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-fr
Navigation:
Lists: gentoo-user-fr: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-fr@g.o
From: Michel Paquet <michel-paquet@...>
Subject: Re: probleme réseau wifi e t samba
Date: Tue, 01 Nov 2005 12:43:10 -0500
Jacques Montier a écrit :

> Bonjour,
>
> Voilà quelques problèmes rencontrés avec un réseau wifi et le 
> démarrage de Samba.
> Le réseau wifi LAN est constitué de 2 pc fixes (Gentoo et Win2000Pro) 
> + cartes PCI wifi MSI et d'un portable (WinXP) + carte wifi pcmcia.
> Le point d'accès (mode infrastructure avec adressage dynamique) est un 
> modem routeur Netgear relié au net.
> Samba est installé sur le pc Gentoo pour pouvoir partager les données 
> entre les trois ordinateurs.
> Sur ce pc, ra0 est l'interface réseau (pilote rt2500).
> Une fois sur deux, au démarrage du pc Gentoo, l'affichage de la mise 
> en service de l'interface ra0 n'apparait pas et tout se bloque à la 
> hauteur du lancement du démon smbd.
> Il faut un Ctrl +c pour pouvoir continuer l'installation du système.
> Après ça, le pc a bien un accès internet, mais les démons smbd et nmbd 
> ne sont évidemment pas lancés, il est alors impossible d'accèder aux 
> deux autres ordinateurs.
> En faisant un /etc/init.d/samba restart, ça fonctionne.
> La question est :
> Pourquoi ce disfonctionnement aléatoire ?
> Est-ce un problème de timing entre l'attibution de l'adresse dynamique 
> par le routeur et le lancement de samba ?
> Avez-vous un idée ?
> Merci d'avance de votre aide.
>
> Jacques
>
A mon avis, l'attribution DHCP ne se fait pas en dedans du temps 
résonable. Le fait d'appuyé sur Ctrl-C n'a pour effet que d'annulé la 
demande du client DHCP et poursuivre l'initialition, ce qui ne permet 
pas à tout les services dépendant du réseau de démarrer (dans ton cas, 
samba)... Sinon, peut-être que le signal n'est pas optimal. Je 
vérifirais dans c'est 2 directions dabors

Petite vérification, /etc/init.d/net.ra0 est bien lier à 
/etc/init.d/net.lo?? est-il bien installé dans le rc (rc-update add 
net.ra0 default) ?

Michel Paquet


-- 
gentoo-user-fr@g.o mailing list


Replies:
Re: probleme réseau wifi e t samba
-- Jacques Montier
References:
probleme réseau wifi et samba
-- Jacques Montier
Navigation:
Lists: gentoo-user-fr: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: probleme réseau wifi et samba
Next by thread:
Re: probleme réseau wifi e t samba
Previous by date:
Re: probleme réseau wifi et samba
Next by date:
Re: probleme réseau wifi e t samba


Updated Jun 17, 2009

Summary: Archive of the gentoo-user-fr mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.