Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user-fr
Navigation:
Lists: gentoo-user-fr: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user-fr@g.o
From: Jean-Philippe ROPA <ehouf@...>
Subject: Re: Re: Re: libc.so.6 en double
Date: Sun, 18 Sep 2005 11:07:11 +0200
Christophe PEREZ a écrit :

>Le Sun, 18 Sep 2005 03:25:47 +0200, Jean-Philippe ROPA a écrit :
>
>  
>
>>J'ai essayé mais le paquet  glibc-2.3.4.20041102
>>est dit masqué par mon profil et je ne sais pas le démasquer
>>(/etc/portage/package.unmask n'a aucun effet)
>>    
>>
>
>Moi, dans l'arbre portage, je ne vois pas de glibc-2.3.4.20041102, mais
>plutôt 2 packages glibc-2.3.4.20041102-r1 et glibc-2.3.4.20041102-r2
>
>Comment as-tu fais pour savoir de quel package exactement venait la lib
>fautive ?
>Tu peux peut-être essayer avec l'un de ces deux là...
>
>  
>
Effectivement, il n'y a pas de glibc-2.3.4.20041102 dans mon arbre
actuel.  Retour en arrière :

gimp plante en faisant appel à libc.so.6
locate libc.so.6 me retourne deux résultats :
/usr/lib64/libc.so.6 -> libc-2.3.4.so et le lien /lib64/libc.so.6 ->
libc-2.3.5.so
Je décide de supprimer glibc-2.3.4 pour éliminer libc-2.3.4.so
(en conflit avec libc-2.3.5.so) gimp tourne alors bien
Mais, pas de glibc-2.3.4 installé pour portage.
Je recherche donc des traces de glibc-2.3.4 :
locate *glibc-2.3.4* me retourne l'existence de
/usr/var/db/pkg/sys-libs/glibc-2.3.4.20041102

*Là, je ne comprends plus, normalement les paquets installés
sont stockés dans /var/db/pkg/ et non /usr/var/db/pkg/*

Curiosité aidant, j'essaye ls /usr/var/db/pkg/* et voici des
paquets installés ou pas ? :
/usr/var/db/pkg/app-arch:
bzip2-1.0.2-r5/  gzip-1.3.5-r5/  ncompress-4.2.4-r1/  tar-1.14/
...
/usr/var/db/pkg/sys-apps:
baselayout-1.9.4-r7/    diffutils-2.8.7/      gawk-3.1.3-r2/ 
net-tools-1.60-r9/  texinfo-4.7-r1/
coreutils-5.2.1-r4/     file-4.12/            grep-2.5.1-r6/ 
portage-2.0.51.19/
debianutils-1.16.7-r4/  findutils-4.1.20-r1/  less-382-r2/    sed-4.0.9/
...
/usr/var/db/pkg/sys-libs:
glibc-2.3.4.20041102/  ncurses-5.4-r5/  zlib-1.2.2/

Que signifie les paquets listés dans /usr/var/db/pkg/ ?
J'ai l'impression d'avoir loupé mon installation :'( ,
mais je ne comprends pas comment ?

Jean-Philippe

-- 
gentoo-user-fr@g.o mailing list


References:
libc.so.6 en double
-- Jean-Philippe ROPA
Re: libc.so.6 en double
-- Christophe PEREZ
Re: Re: libc.so.6 en double
-- Jean-Philippe ROPA
Re: Re: libc.so.6 en double
-- Christophe PEREZ
Navigation:
Lists: gentoo-user-fr: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Re: libc.so.6 en double
Next by thread:
ou est mod_php 5 ??
Previous by date:
Re: Re: libc.so.6 en double
Next by date:
ou est mod_php 5 ??


Updated Jun 17, 2009

Summary: Archive of the gentoo-user-fr mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.