Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user
Navigation:
Lists: gentoo-user: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user@g.o
From: 张春江 <zhangchunjiangrj@...>
Subject: Re: sys-boot/plymouth could not work
Date: Wed, 4 Apr 2012 12:01:58 +0800 (CST)
On 2012-04-04 01:19:39,"Canek Peláez Valdés" <caneko@...> wrote:
>I do, but I also use systemd. And GRUB2.
I use OpenRC0.9.8.4 and GNU GRUB0.97-r10, maybe that's the difference.

>The /run directory should be created when installing dbus; it's a tmpfs:

I have installed dbus, while I don't have a /run tmpfs.

>So the problem it's not the existance (or not) of the run directory, I
>believe; it's the fact that it's mounted really early in the boot
>process as a tmpfs. So, did you use dracut to generate your initramfs,
>or did you use genkernel? Or you did it by hand?

I don't know how to mount /run before the boot process, 
I used dracut to generate my initramfs:
# dracut -H -f
I: *** Including module: dash ***
I: *** Including module: i18n ***
I: *** Including module: plymouth ***
I: *** Including module: kernel-modules ***
I: *** Including module: resume ***
I: *** Including module: rootfs-block ***
I: *** Including module: terminfo ***
I: *** Including module: udev-rules ***
I: Skipping udev rule: 50-udev.rules
I: Skipping udev rule: 95-late.rules
I: *** Including module: usrmount ***
I: *** Including module: base ***
I: *** Including module: fs-lib ***
I: *** Including module: shutdown ***
I: Skipping program kexec as it cannot be found and is flagged to be optional
I: *** Including modules done ***
I: Wrote /boot/initramfs-3.2.1-gentoo-r2.img:
I: -rw-r--r-- 1 root root 2773237 Apr  4 11:52 /boot/initramfs-3.2.1-gentoo-r2.img


Replies:
Re: sys-boot/plymouth could not work
-- Canek Peláez Valdés
References:
sys-boot/plymouth could not work
-- 张春江
Re: sys-boot/plymouth could not work
-- Canek Peláez Valdés
Navigation:
Lists: gentoo-user: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: sys-boot/plymouth could not work
Next by thread:
Re: sys-boot/plymouth could not work
Previous by date:
Re: Apache upgrade to 2.4 error AH00027: Buggy authn provider failed to set user
Next by date:
Re: sys-boot/plymouth could not work


Updated May 04, 2012

Summary: Archive of the gentoo-user mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.