Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-user
Navigation:
Lists: gentoo-user: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-user@g.o
From: Neil Bothwick <neil@...>
Subject: Re: "lvm failed to start"
Date: Wed, 4 Apr 2012 09:39:20 +0100
On Tue, 03 Apr 2012 18:09:26 -0700, walt wrote:

> This is an ~amd64 machine, up to date as of today.  The strange thing
> is that lvm did *not* fail to start -- it's working perfectly.
> 
> Now, being an Incorrigible Old Fart(TM) I'm still using openrc, and
> who knows what evil lurks in that paleolithic package?  :p
> 
> Anyone else getting this (false) alarm during boot?

It is not really a false alarm, LVM does fail here but tries again later
on and succeeds. https://bugs.gentoo.org/show_bug.cgi?id=409921 covers it
and the workaround in comment 2 does it for me.

Basically, LVM is trying to write its lockfile to a readonly filesystem.
I'm going to try mounting /run on tmpfs in my initramfs as that is where
it is mounted now, but apparently too late for the first attempt at
starting LVM.


-- 
Neil Bothwick

"If Micro built cars, the worlds population would be in decline"
Attachment:
signature.asc (PGP signature)
References:
"lvm failed to start"
-- walt
Navigation:
Lists: gentoo-user: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: "lvm failed to start"
Next by thread:
Re: "lvm failed to start"
Previous by date:
Re: Re: After /usr conflation: why not copy booting software to /sbin rather than initramfs?
Next by date:
Re: Re: After /usr conflation: why not copy booting software to /sbin rather than initramfs?


Updated May 04, 2012

Summary: Archive of the gentoo-user mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.