Gentoo Archives: gentoo-web-user

From: Renat Lumpau <rl03@g.o>
To: gentoo-web-user@l.g.o
Subject: [gentoo-web-user] status of w-c
Date: Mon, 10 Jul 2006 01:08:54
Message-Id: 20060710010800.GI32055@woodpecker.gentoo.org
Hi,

I've gone through the bugs reported against w-c to see where we stand.

1) Show-stoppers:

http://bugs.gentoo.org/show_bug.cgi?id=124440: webapp.eclass calls emerge
        Suggested solution (webapp-cleaner) posted to the bug. I plan to add it
        to the tree in about a week unless there are objections.

http://bugs.gentoo.org/show_bug.cgi?id=136959: webapps gets uninstalled on
reinstall w/ USE="vhost"
        Suggested solution (eclass fixes) posted to
        http://www.vhost-tools.org/ticket/32 . I would like to fix this ASAP
        without waiting for w-c-1.60. Stuart and wrobel, please review and post
        comments.

http://bugs.gentoo.org/show_bug.cgi?id=130371: webapp-config not installing
files with correct permissions
        w-c removes +x on files copied to vhost, which breaks CGI apps. This
        needs to be fixed in w-c. wrobel: any thoughts on the timeline?

2) Needed functionality:

http://www.vhost-tools.org/ticket/6: allow webapp-config to install multiple
apps in the same directory
        Needed for plugins etc

3) Needs closure:

http://bugs.gentoo.org/show_bug.cgi?id=124443: webapp.eclass: SLOT mishandling
        I'm planning to remove the warning from the eclass tomorrow. Since
        Halcy0n retired, we should check with QA again whether PVR is
        acceptable.

IMO, the rest can wait. Stuart and wrobel: I would very much appreciate your
comments on the above bugs and proposed solutions. Also, wrobel, it'd be great
to get your thoughts on the timeline for w-c-1.60.

Best,
-- 
Renat Lumpau       all things web-apps
C6A838DA           04AF B5EE 17CB 1000 DDA5  D3FC 1338 ADC2 C6A8 38DA

Replies

Subject Author
Re: [gentoo-web-user] status of w-c Gunnar Wrobel <wrobel@g.o>