Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-web-user
Navigation:
Lists: gentoo-web-user: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-web-user@g.o
From: Dirk Tilger <dirk@...>
Subject: Making use of webapp optional
Date: Sun, 4 Mar 2007 11:56:10 +0400
Hi guys,

I'm trying to enhance the mapserver ebuild to support building no CGI at 
all. The software can be built as extension for many programming 
languages and a CGI is not strictly necessary.

It was suggested in #gentoo-web on freenode that I should use the 'cgi' 
USE flag for this purpose. I wrapped all calls to webapp functionality 
with `if use cgi` or an equivalent, but then I'm getting at the very end 
of the build process:

| >>> Original instance of package unmerged safely.
|  * 
|  * This ebuild did not call webapp_src_install() at the end
|  * of the src_install() function
|  * 
|  * Please log a bug on http://bugs.gentoo.org
|  * 
|  * You should use emerge -C to remove this package, as the
|  * installation is incomplete
|  * 
| 
| !!! ERROR: sci-geosciences/mapserver-4.10.0 failed.
| Call stack:
|   ebuild.sh, line 1595:   Called qa_call 'pkg_postinst'
|   environment, line 4827:   Called pkg_postinst
|   ebuild.sh, line 1304:   Called webapp_pkg_postinst
|   webapp.eclass, line 462:   Called die
| 
| !!! Ebuild did not call webapp_src_install() - report to http://bugs.gentoo.org
| !!! If you need support, post the topmost build error, and the call stack if relevant.
| !!! A complete build log is located at '/var/tmp/portage/sci-geosciences/mapserver-4.10.0/temp/build.log'.
| 
| !!! FAILED postinst: 1
| !!! This ebuild is from an overlay: '/home/dirk/overlay'

When I do run the webapp_src_install() function, I get at the end:

|  * Running //usr/sbin/webapp-config -I -h localhost -u root -d /mapserver mapserver 4.10.0
|  * Fatal error: Your configuration file sets the server type "Apache"
|  * Fatal error: but the corresponding package does not seem to be installed!
|  * Fatal error: Please "emerge >=net-www/apache-1.3" or correct your settings.
|  * Fatal error(s) - aborting
| 
|   * Running //usr/sbin/webapp-cleaner -p -C mapserver

The only solution I have found so far is to wrap 'inherit webapp' with
`use cgi` everything works, but then my ebuild gets rejected, because
that would prevent metacaching as was pointed out to me at bugzilla.

Any suggestions would be highly appreciated.
Thanks in advance,
Dirk.
-- 
gentoo-web-user@g.o mailing list


Replies:
Re: Making use of webapp optional
-- Renat Lumpau
Navigation:
Lists: gentoo-web-user: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
mediawiki-1.6.x and 1.7.x
Next by thread:
Re: Making use of webapp optional
Previous by date:
mediawiki-1.6.x and 1.7.x
Next by date:
Re: Making use of webapp optional


Updated Jun 17, 2009

Summary: Archive of the gentoo-web-user mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.