Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: www-redesign
Navigation:
Lists: www-redesign: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: www-redesign@g.o
From: Curtis Napier <curtis119@g.o>
Subject: xhtml-1.1
Date: Sat, 07 Jan 2006 20:07:27 -0500
While I'm waiting for Aaron to create a new logo I am taking the time to 
upgrade the site to xhtml-1.1. I put this in a blog post yesterday and 
already have received numerous reports that I am doing it incorrectly.

I want everyone on the list to feel confident in this change:


The specification for xhtml-1.1 says that the server *should* send 
application/xml+xhtml in the HTTP header but that it *can* send 
text/html in order to remain backwards compatible with older user 
agents, IE for example. As long as the doctype is set correctly (and it 
is) it is still valid xhtml-1.1.

In fact, if you use the validator, http://validator.w3.org, and let it 
auto detect the doctype it correctly detects xhtml-1.1 and validates the 
page using that specification (ignore the errors, I'm still workin' on 
it). Browsers will also detect it, including IE, and use the correct 
specs to render the page. They also render the page in Standards 
Compliance Mode, including IE.

Trust me on this, I researched it *extensively* before making the jump 
to xhtml-1.1, I didn't just blindly decide to change. I read the entire 
xhmtl-1.1 specification. I didn't just skim it or skip any parts I read 
the entire thing. I read the XSLT-1.0 specification to make sure I was 
doing it right in the xsl. I also read TONS of threads from all over the 
world discussing this, including from IE support sites, apache, mozilla, 
w3c (extensively) and web designer sites.

MS officially suggests using text/html in the HTTP header when serving 
xhtml-1.1 documents to IE. Mozilla, Opera, Firefox, Konqueror can all 
correctly use application/xml+xhtml and officially suggest that is what 
you send in the HTTP header but **ALL** of them are also backwards 
compatible with text/html.

None of the text browsers, as far as I know, can use 
application/xml+xhtml yet but, just like IE, they can correctly render 
an xhtml-1.1 page validly and in Standards Compliance Mode with 
text/html in the HTTP header.

When viewing pages that have been saved locally **all** browsers can 
correctly load and render the pages if you change the extension from 
.xml to .html, just like pages that end in .php for example.

So, to sum it up:

The site is validly serving XHTML-1.1 (except for the errors I haven't 
fixed yet) that is recognized by all browsers and correctly rendered. 
The server doesn't have to send application/xml+xhtml in the HTTP header 
in order for it to be valid, it can send text/html too.
-- 
www-redesign@g.o mailing list


Replies:
Re: xhtml-1.1
-- Xavier Neys
Navigation:
Lists: www-redesign: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Slight Color Problem on Gentoo Handbook
Next by thread:
Re: xhtml-1.1
Previous by date:
Re: status of http://wwwredesign.gentoo.org
Next by date:
Re: xhtml-1.1


Updated Jun 17, 2009

Summary: Archive of the www-redesign mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.