Gentoo Archives: gentoo-accessibility

From: Spider <spider@g.o>
To: gentoo-accessibility@l.g.o
Subject: Re: [gentoo-accessibility] Package installation
Date: Wed, 12 May 2004 19:55:17
In Reply to: [gentoo-accessibility] Package installation by "David Renström"
begin  quote
On Wed, 12 May 2004 21:12:37 +0200
David Renström <david.renstrom@×××××××××××××××××××××.com> wrote:

> Hi again! > > I've got another question: How do you install a package whose name > contains dashes (-), e.g. realplayer8-r7? Or links-2 for that matter. > I always get an error saying something about a key and that I should > probably add an equal sign. I guess I'm missing something fundamental > here, so please tell me how to get around this. It's very annoying! > :-) And speaking of annoying, I'm sorry for asking about alot of stuff > that strictly doesn't have anything to do with accessibility, but the > list doesn't seem to be overloaded for the moment anyway.
Okay, I'll try to help here. if you want to install an -exact- version of something, you need to tell portage that by using the format : emerge =name-version here are some examples: emerge -p xchat [ebuild R ] net-irc/xchat-2.0.8-r1 emerge -p "<xchat-2" [ebuild N ] gnome-base/gnome-panel-1.4.2-r2 [ebuild N ] net-irc/xchat-1.8.11-r1 emerge -p "=xchat-1.8.11" [ebuild N ] gnome-base/gnome-panel-1.4.2-r2 [ebuild N ] net-irc/xchat-1.8.11 emerge -p "=xchat-2.0.6-r1" [ebuild UD] net-irc/xchat-2.0.6-r1 [2.0.8-r1] Do theese examples make it clearer? //Spider -- begin .signature Tortured users / Laughing in pain See Microsoft KB Article Q265230 for more information. end


Subject Author
Re: [gentoo-accessibility] Package installation "David Renström" <david.renstrom@×××××××××××××××××××××.com>