Gentoo Archives: gentoo-alpha

From: Jeff Donsbach <jeff_donsbach@×××××.com>
To: gentoo-alpha@l.g.o
Subject: [gentoo-alpha] problem upgrading the toolchain
Date: Tue, 06 Dec 2005 14:28:45
Hi folks,

I'm trying to get Gentoo installed on a new (to me)
Miata. I got the base system installed and got
upgraded to the kernel. Looks good so far. By
the way, the 2005.1 LiveCD wouldn't boot on this
system with the default 2.6 kernel either. I had to
boot the 2.4 kernel and install that way, then upgrade
to the 2.6 kernel. But, that isn't my current problem.

I'm having trouble updating the tool chain. GLIBC
seems to have rebuilt fine with NPTL support. As an
example, here is the log file when trying to emerge
binutils -

alpha1 build # more config.log
This file contains any messages produced by compilers
running configure, to aid debugging if configure makes
a mistake.

configure:595: checking host system type
configure:616: checking target system type
configure:634: checking build system type
configure:689: checking for a BSD compatible install
configure:742: checking whether ln works
configure:766: checking whether ln -s works
configure:1779: checking for gcc
configure:1892: checking whether the C compiler
(/usr/bin/gcc -mieee -mcpu=ev56 -pipe -O2 ) works
configure:1908: /usr/bin/gcc -o conftest -mieee
-mcpu=ev56 -pipe -O2   conftest.c  1>&5
gcc: Internal error: Segmentation fault (program as)
Please submit a full bug report.
See <URL:> for instructions.
configure: failed program was:

#line 1903 "configure"
#include "confdefs.h"



Now, the strange part is, if I make a conftest.c with
the two lines above and manually run "usr/bin/gcc -o
conftest -mieee -mcpu=ev56 -pipe -O2   conftest.c" ,
it works just fine!

Any idea what could be wrong? Other ebuilds seem to
fail the same way. Oh, my gcc version is:
alpha1 build # gcc --version
gcc (GCC) 3.3.2 20040119 (Gentoo Linux 3.3.2-r7,

My glibc version is 2.3.5-r3 with NPTL support in my
USE flags.

Jeff D

Yahoo! DSL – Something to write home about. 
Just $16.99/mo. or less. 

gentoo-alpha@g.o mailing list


Subject Author
Re: [gentoo-alpha] problem upgrading the toolchain "Nils o. Janus" <NoJ@××××××××××××.de>