Gentoo Archives: gentoo-alt

From: Fabian Groffen <grobian@g.o>
To: gentoo-alt@l.g.o
Subject: Re: [gentoo-alt] Re: Gentoo Prefix on Interix 6.1
Date: Tue, 21 Apr 2009 08:29:03
In Reply to: [gentoo-alt] Re: Gentoo Prefix on Interix 6.1 by Markus Duft
On 21-04-2009 08:43:27 +0200, Markus Duft wrote:
> > > I also tried 'emerge --nodeps -1 portage' but got the same failure. > > > It's not just sys-apps/portage that gets this error, either, it's > > > every package. > > > > > > Any ideas? > > just to get the list informed: solved this on IRC: > > emerge -av1 --nodeps "=sys-apps/portage-" > > is required to get portage back up and working... current interix CD > image portage refuses to do anythin wrt dependency resolution, or even > parsing of EAPI=prefix ebuild (so he doesn't mask them but bails out - > argh..)
% env EAPIPREFIX='' emerge -1av --nodeps portage should do it as well, which immediately updates your vdb completely. Sorry for the hassle, but I feel we have to go through this to get further. -- Fabian Groffen Gentoo on a different level