Gentoo Archives: gentoo-alt

From: Michael Haubenwallner <haubi@g.o>
To: gentoo-alt@l.g.o
Subject: Re: [gentoo-alt] Prefix on AIX
Date: Fri, 14 Jan 2011 08:24:56
In Reply to: Re: [gentoo-alt] Prefix on AIX by Perry Smith
On 01/13/2011 06:15 PM, Perry Smith wrote:
> On Dec 23, 2010, at 10:57 AM, Michael Haubenwallner wrote: >> Hi Perry, >> >> with svn-trunk of prefix-launcher and the next prefix-tree snapshot, >> you most likely should be able to get a working Prefix on AIX. >> >> /haubi/ (on xmas holidays until 2010-01-10) > > I hope you had a nice vacation. I didn't want to start asking for help too soon. I don't want to wear out my welcome.
Thank you, was just fine!
> I poked at what I have. Got past a few issues and got up to building ssh and died with: > > ld: 0711-317 ERROR: Undefined symbol: .EVP_des_cbc > ld: 0711-317 ERROR: Undefined symbol: .EVP_md5 > ld: 0711-317 ERROR: Undefined symbol: .EVP_aes_128_cbc
This is interesting: I've built openssh-5.5_p1-r2 just fine here on both AIX 5.3 and 6.1, however without any USE-flags.
> I'm willing to start completely over is that will save the two of us grief. > > Let me know your suggestions. I'm not in a big hurry at all.
Good to know: I've just found a problem with zlib, which is built without SONAME emulation again. Fixing this will break binaries linked against, so you'll best start over once I've sorted it out. Additionally, I'd like to add some help into ld-wrapper to get at least some chance for a workaround to drop the technical need to always start over in such cases. I'll tell again once this is done. Remember to self: It still has to be discussed with libtool upstream which variant of SONAME emulation to finally choose, also to report consistent aix-patches to upstreams of packages not using libtool (like zlib). /haubi/ -- Michael Haubenwallner Gentoo on a different level