Gentoo Archives: gentoo-amd64

From: Mark <whitetr6@×××××.com>
To: gentoo-amd64@l.g.o
Subject: Re: [gentoo-amd64] emerge --emptytree problem
Date: Sun, 10 Jul 2005 13:57:29
In Reply to: Re: [gentoo-amd64] emerge --emptytree problem by Sean Sullivan
I'll have to try again and see, I've already rebooted to start again.
When it fails (most recently it was at the qt-xxxx package install, it
has the usual "post the topmost error" message. But since I'm in the
console, I can't scroll up higher than the current screen displays.
How do I get to the error you would need to see? Thanks for the

On 7/10/05, Sean Sullivan <sean@××××××××××.org> wrote:
> On Sunday 10 July 2005 09:25, Mark wrote: > > I'm rebuilding my system from scratch, using 2005 and a stage 2 build. > > It keeps failing in the emerge --emptytree system process. I suspect > > my make.conf is the problem. So a couple questions... > > > > 1. On the USE flags, this time around, I put in everything that > > sounded like I wanted, which ended up being a very long list. Am I > > better off having a very short list of USE flags, as shown in the > > example in the docs? > > > > 2. I have -march=athlon64 in my make.conf file. My processor is an > > AMD64 Athlon 3200+. Is that the correct march= setting? Maybe that's > > my whole problem rather than my USE flags list?? > > > > Thanks all, > > -- > > Mark > > [unwieldy legal disclaimer would go here - feel free to type your own] > > march=athlon64 should be fine for your CPU. I use it and have an AMD64 3000+. > How exactly does the emerge fail? What is the error you see? Doubtful it has > anything to do with your USE flags, so we'll prob need to see the error. > > Here is my make.conf for comparison (and I have a lot of USE flags) > -------------------------- > CHOST="x86_64-pc-linux-gnu" > CFLAGS="-march=athlon64 -O2 -pipe" > CXXFLAGS="${CFLAGS}" > > ACCEPT_KEYWORDS="~amd64" > MAKEOPTS="-j2" > > USE="-gnome -kde -gtk -arts acpi alsa X audiofile avi -bonobo > cdparanoia cdr crypt cups dbm divx4linux dvd dvdread gtk2 > encode imagemagick mailwrapper mozilla mpeg mysqli multilib > nvidia ogg oggvorbis oss opengl pam perl python qt samba ssl > mysql php xine amd64 apache2 cups acl xml readline libclamav" > -------------------------- > > -Sean >
-- Mark [unwieldy legal disclaimer would go here - feel free to type your own] -- gentoo-amd64@g.o mailing list


Subject Author
Re: [gentoo-amd64] emerge --emptytree problem Mathieu Seigneurin <mseigneurin@×××××××.fr>
Re: [gentoo-amd64] emerge --emptytree problem Zac Medico <zmedico@×××××.com>
Re: [gentoo-amd64] emerge --emptytree problem Peter Humphrey <prh@××××××××××.uk>